Syntax Highlighter for Theme/Plugin Editor

Description

An easy to use, with intuitive interface, WordPress plugin that replaces the default Theme and Plugin Source Code Editor with an enhanced editor by a CodeMirror library. The WordPress default Theme Editor (in Appearance => Editor) and Plugin Editor (in Plugins => Editor) is great for doing some custom changes to your Themes or Plugins files, although it is rather limited. This is where the “Syntax Highlighter for Theme/Plugin Editor” can help. With an enhanced source code editor you can see a code with syntax highlighting, and with line numbering, so you can easily read your code and detect any errors.

This plugin give you finer control over editor, it can be configured on the plugin settings page. You can chose from 36 different color themes for your editor. If you want more options then tell me and I will be happy to add it.

This plugin is just plug and play, no tedious configurations or hacks, just install, enable and start using your new enhanced Theme and Plugin Editor.

Features

  • Lightweight and fast
  • Secure code with using clear coding standards
  • Intuitive interface with many settings
  • Cross browser compatible (work smooth in any modern browser)
  • Compatible with all WordPress themes
  • RTL compatible (right to left)
  • Translation ready

Key features include…

  • Syntax highlighting (by CodeMirror)
  • Huge selection of color schemes (36 themes)
  • Line numbering
  • Editor allow for tab indentation
  • Live preview
  • And much, much more!

Supported languages:

  • XML
  • HTML
  • CSS
  • PHP
  • JavaScript (.js)
  • Markdown (.txt)

Translation

This plugin is ready for translation and has already been translated into several languages.

  • English (default)
  • Russian

If you want to help translate this plugin then please visit the translation page.

Contribution

Developing plugins is long and tedious work. If you benefit or enjoy this plugin please take the time to:

“Syntax Highlighter for Theme/Plugin Editor” is one of the personal software projects of Arthur Gareginyan.

License

This plugin is licensed under the GNU General Public License, version 3 (GPLv3) and is distributed free of charge.
Commercial licensing (e.g. for projects that can’t use an open-source license) is available upon request.

Credits

Links

Screenshots

  • Plugin settings page.
  • Default WP Plugin Editor.
  • Plugin Editor that provided by this plugin (color theme: ambiance).
  • Plugin Editor that provided by this plugin (color theme: default).
  • Theme Editor that provided by this plugin (color theme: ambiance).

Installation

Install “Syntax Highlighter for Theme/Plugin Editor” just as you would any other WordPress Plugin.

Automatically via WordPress Admin Panel:

  1. Log into Admin Panel of your WordPress website.
  2. Go to “Plugins” -> “Add New“.
  3. Find this plugin and click install.
  4. Activate this plugin through the “Plugins” tab.

Manually via FTP access:

  1. Download a copy (ZIP file) of this plugin from WordPress.org.
  2. Unzip the ZIP file.
  3. Upload the unzipped catalog to your website’s plugin directory (/wp-content/plugins/).
  4. Log into Admin Panel of your WordPress website.
  5. Activate this plugin through the “Plugins” tab.

After installation and activation, the “Syntax Highlighter for Theme/Plugin Editor” menu item will appear in the “Settings” section of Admin Panel. Click on it in order to view the plugin settings page.

More help installing plugins

FAQ

Installation Instructions

Install “Syntax Highlighter for Theme/Plugin Editor” just as you would any other WordPress Plugin.

Automatically via WordPress Admin Panel:

  1. Log into Admin Panel of your WordPress website.
  2. Go to “Plugins” -> “Add New“.
  3. Find this plugin and click install.
  4. Activate this plugin through the “Plugins” tab.

Manually via FTP access:

  1. Download a copy (ZIP file) of this plugin from WordPress.org.
  2. Unzip the ZIP file.
  3. Upload the unzipped catalog to your website’s plugin directory (/wp-content/plugins/).
  4. Log into Admin Panel of your WordPress website.
  5. Activate this plugin through the “Plugins” tab.

After installation and activation, the “Syntax Highlighter for Theme/Plugin Editor” menu item will appear in the “Settings” section of Admin Panel. Click on it in order to view the plugin settings page.

More help installing plugins

Q. Will this plugin work on my WordPress.COM website?

A. Sorry, this plugin is available for use only on self-hosted (WordPress.ORG) websites.

Q. Can I use this plugin on my language?

A. Yes. This plugin is ready for translation and has already been translated into several languages. But If your language is not available then you can make one. The POT file is included and placed in the “languages” folder. Just send the PO file to me at the arthurgareginyan@gmail.com and I will include this translation within the next plugin update. Many of plugin users would be delighted if you share your translation with the community. Thanks for your contribution!

Q. How does it work?

A. Simply go to the plugin settings page, select the desired settings and click the “Save changes” button. Enjoy your fancy Theme/Plugin Editor. It’s that simple!
You can find the plugin settings page at “WP Admin Panel” -> “Settings” -> “Syntax Highlighter for Theme/Plugin Editor“.

Q. Does this plugin provide a syntax highlighting for the Post/Page Editor?

A. No, only the Theme/Plugin Editor supports. For the Post/Page Editor you can use my another plugin that called the Syntax Highlighter for Post/Page HTML Editor.

Q. My theme uses a file type that is not supported by this plugin, how can I get it added?

A. If there is a filetype that is not supported by this plugin, just visit the support page and fill out the support form. I will do my best to include it in the next release of plugin.

Q. Does this plugin requires any modification of the theme?

A. Absolutely not. This plugin is configurable entirely from the plugin settings page that you can find in the Admin Panel of your WordPress website.

Q. Does this require any knowledge of HTML or CSS?

A. This plugin can be configured with no knowledge of HTML or CSS, using an easy-to-use plugin settings page. But you need to know the HTML or CSS in order to add/remove/modify the HTML or CSS code by using this plugin.

Q. It’s not working. What could be wrong?

A. As with every plugin, it’s possible that things don’t work. The most common reason for this is a web browser’s cache. Every web browser stores a cache of the websites you visit (pages, images, and etc.) to reduce bandwidth usage and server load. This is called the browser’s cache.​ Clearing your browser’s cache may solve the problem.

It’s impossible to tell what could be wrong exactly, but if you post a support request in the plugin’s support forum on WordPress.org, I’d be happy to give it a look and try to help out. Please include as much information as possible, including a link to your website where the problem can be seen.

Q. The last WordPress update is preventing me from editing my website that is using this plugin. Why is this?

A. This plugin can not cause such problem. More likely, the problem are related to the settings of the website. It could just be a cache, so please try to clear your website’s cache (may be you using a caching plugin, or some web service such as the CloudFlare) and then the cache of your web browser. Also please try to re-login to the website, this too can help.

Q. Where to report bug if found?

A. Please visit the Dedicated Plugin Page on GitHub and report.

Q. Where to share any ideas or suggestions to make the plugin better?

A. Any suggestions are very welcome! Please send me an email to arthurgareginyan@gmail.com. Thank you!

Q. I love this plugin! Can I help somehow?

A. Yes, any financial contributions are welcome! Just visit my website, click on the donate button, and thank you!

Reviews

Better plugin I used ! Отличный плагин!

Thanks to Arthur Gareginyan for a good useful plugin! Sone plugins does not highlight the syntax of /wp-admin/theme-editor.php?file=style.css but your plugin do.

Спасибо автору за лучший плагин для подсветки синтаксиса в WordPress!

Read all 1 review

Contributors & Developers

“Syntax Highlighter for Theme/Plugin Editor” is open source software. The following people have contributed to this plugin.

Contributors

Changelog

4.4.1

  • The HTTPS mixed content issue fixed by changing all links to HTTPS.
  • Content of the “FAQ” section updated.

4.4

  • On the plugin settings page, text of buttons are corrected.
  • On the plugin settings page, the information about the plugin version number moved to header section.
  • Some mention of constants replaced with variables for easier access.
  • Content of the “Usage” tab updated.
  • Content of the “FAQ” tab updated.
  • Added load of the jQuery library on the plugin settings page.

4.3

  • To the plugin settings page added information about the plugin version number.
  • The “Tested up to:” comment changed to 4.8 after full testing process.
  • The “version.php” file renamed to “versioning.php”.
  • The “versioning.php” file updated to new version.
  • The “_plugin_version_number” function renamed to the “_versioning”.

4.2

  • Compatibility with PHP version 5.2 improved.
  • Added function for generating the plugin constants.
  • Some constants now get the value from the plugin header data.
  • The “_plugin_version_number” function improved.
  • Added file “upgrade.php” for future upgrades.

4.1.1

  • Fixed the bug due to which the “Warning: Constants may only evaluate to scalar values in” warning are displayed.

4.1

  • Added new constants: “_SLUG”, “_PREFIX”, “_SETTINGS” and “_NAME”.
  • Value of the “_VERSION” constant replaced with information from the plugin header data.
  • All references to the plugin name, slug, prefix are replaced with constants.
  • Added function that render checkboxes and fields for saving plugin settings to database.
  • Added prefix to the name of the variable in ‘wp_localize_script’ WP function, to prevent conflicts.
  • The “_load_scripts_base” function improved.
  • The “name” attribute removed from the “form” tag.
  • Code formatting improved.
  • F.A.Q. section updated.

4.0.1

  • Fixed the bug due to which the the “Warning: Illegal string offset ‘version’ in” and the “Warning: Illegal string offset ‘old_version’ in” warnings are displayed. (Thanks to Sven Brill)

4.0

  • The design of the plugin settings page is completely redone.
  • Fixed the ‘SMEDIABT_’ error.
  • Added additional donate link to the “Plugins” page.
  • Readme for translations updated.
  • Advertisement banner removed.
  • The ‘Using’ section renamed to ‘Usage’.
  • My Unicode signature added to the main file.
  • The donate button replaced with new.
  • The ‘Donate’ section renamed to ‘Support’.
  • The ‘donate.png’ image removed.
  • Options from the settings page moved to a separate file.
  • The “Usage” section removed from the sidebar area.
  • Added stylized descriptions of sections on the “Settings” tab.
  • Additional “Support” section added.
  • Plugin renamed from the “Syntax Highlighter for WP Editor” to “Syntax Highlighter for Theme/Plugin Editor”.
  • Added tab navigation menu for the settings page.
  • Added additional tabs on the settings page.
  • Code of the ‘admin.css’ file improved and better commented.
  • The ‘bootstrap-checkbox.min.js’ file renamed to ‘bootstrap-checkbox.js’.
  • A full version of the Bootstrap framework is integrated.
  • The ‘SHighlighterForWPE_load_scripts’ function renamed to ‘SHighlighterForWPE_load_scripts_admin’.
  • The ‘SHighlighterForWPE_prepare’ function renamed to ‘SHighlighterForWPE_load_scripts_base’.
  • Added the CSS code for the custom list numbers on the plugin settings page.
  • The main font is changed to “Verdana”.
  • All PHP and HTML code is better formatted.
  • The header on the settings page of plugin is redesigned.
  • The “LICENSE.txt” file renamed to “license.txt”.
  • The “humans.txt” file added.
  • On the plugin settings page, the “valign=’top'” attribute removed from the “tr” element of HTML table and added the appropriate analog in CSS .
  • The “_service_info” setting added to the data-base.
  • Added function for managing information about the version number of the plugin.
  • Added the “Hello” message that show when the plugin is just installed.
  • Added the “Error” message that show when user is trying to degrade the version number of the plugin.
  • Fixed the parameter that contain the path to source files in all translation files.
  • The POT file updated.
  • Translations updated.

3.2

  • Added the Readme.txt file for translation contribution.
  • Added global constant for plugin text-domain.
  • Translations updated.
  • Ad banner replaced with new.

3.1

  • Added prefixes to the stylesheet and script names when using wp_enqueue_style() and wp_enqueue_script().
  • Added constant for storing the plugin version number.

3.0

  • The structure of files changed.
  • Style sheet of settings page improved and better commented.
  • Style sheet of settings page optimized for mobile devices.
  • JS code improved.
  • Added JavaScript file for settings page.
  • Added JavaScript function of automatic remove the “successful” message after 3 seconds.
  • Checkboxes replaced with cool triggers by using Bootstrap framework and Bootstrap-checkbox component.

2.0.1

  • POT file updated.
  • Russian translation updated.
  • Image “thanks.png” removed.
  • Advertisement replaced by new.
  • Added the subject with plugin name to email address on settings page.
  • Function “SHighlighterForWPE_enqueue_editor_scripts” renamed to “SHighlighterForWPE_load_scripts”.

2.0

  • Text domain changed to “syntax-highlighter-for-wp-editor”.
  • Added compatibility with the translate.wordpress.org.
  • All images are moved to the directory “images”.
  • Image “btn_donateCC_LG.gif” is now located in the “images” directory.

1.2

  • Constants variables added. (Thanks @hsleonis)
  • JS best practice used in editor.js. (Thanks @hsleonis)

1.1

  • Fixed: Undefined variable “readonly”.

1.0

  • Added default values for options.
  • Added support for Markdown files.
  • Added support for XML files.
  • Plugin URI changed to GitHub repository.
  • Added my personal ad about freelance.
  • Added ready for translation (.pot file included).
  • Added Russian translation.
  • Some changes in design of settings page.

0.3

  • Release candidate.
  • Added option “Display line numbers”.
  • Added option “First line number”.
  • Added option “The width of Tab”.

0.2

  • Beta version.

0.1

  • Alfa version.