Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Springest Partners for WordPress

Display relevant courses and trainings from Springest on your website.

This plugin lets you create an automatically generated set of pages on your WordPress website with a listing of relevant trainings and courses from Springest. Our powerful API provides you with extreme flexibility in the selection of the trainings and courses to be displayed.

To use this plugin you will need a Springest API key. If you do not have one yet, please contact our Support Team at support@springest.nl to request one.


  • Easily display relevant courses from Springest on your website
  • Create your own custom groups/pages for the trainings you want to display
  • Use advanced search queries to select extremely relevant trainings and courses from the Springest API
  • Choose between our English, German, Dutch and Belgian API's
  • Seamlessly integrated with WordPress

Requires: 3.0 or higher
Compatible up to: 3.5.2
Last Updated: 2013-1-3
Active Installs: 10+


0 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.