WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

Smart Custom Fields

Smart Custom Fields is a simple plugin that management custom fields.

Smart Custom Fields is a simple plugin that management custom fields.

  • This plugin has loop field function.
  • Supported metadata revision.
  • Supported metadata preview.

Field Types

  • Text
  • Textarea
  • Radio
  • Select
  • Checkbox
  • Wysiwyg editor
  • Image
  • File
  • Relation ( Post Types )
  • Relation ( Taxonomies )
  • Color picker
  • Date picker
  • Boolean

How to get meta data ?

Post meta data

This method can get any meta data.

SCF::get( 'field-name' )

This method can get meta data of any group.

SCF::get( 'group-name' )

This method can get all meta data.

SCF::gets()

This method can get any user meta data.

User meta data

SCF::get_user_meta( $user_id, 'field-name' )

This method can get user meta data of any group.

SCF::get_user_meta( $user_id, 'group-name' )

This method can get all user meta data.

SCF::get_user_meta( $user_id )

Term meta data

This method can get any term meta data.

SCF::get_term_meta( $term_id, $taxonomy 'field-name' )

This method can get term meta data of any group.

SCF::get_term_meta( $term_id, $taxonomy, 'group-name' )

This method can get all term meta data.

SCF::get_term_meta( $term_id, $taxonomy )

Custom options page meta data

This method can get any custom options page meta data.

SCF::get_option_meta( $menu_slug, 'field-name' )

This method can get custom options page meta data of any group.

SCF::get_option_meta( $menu_slug, 'group-name' )

This method can get all custom options page meta data.

SCF::get_option_meta( $menu_slug )

Create custom options page

SCF::add_options_page( $page_title, $menu_title, $capability, $menu_slug, $icon_url = '', $position = null );

Register custom fields by the code.

https://gist.github.com/inc2734/9f6d65c7473d060d0fd6

GitHub

https://github.com/inc2734/smart-custom-fields/

Translators

You can send your own language pack to me.

Requires: 3.9 or higher
Compatible up to: 4.7.1
Last Updated: 6 days ago
Active Installs: 7,000+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1