WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

Post Teaser

Post Teaser generates excerpts of posts for the main, archive and category pages, also generate a word count, image count, and estimated reading time.

Post Teaser generates a preview or "teaser" of a post for the main, archive and category pages, with a link underneath to go to the full post page. It includes features to generate a word count, image count, and an estimated reading time.

Reasons you might want to use Post Teaser:

  • You keep putting <!--more--> into your posts
  • You would like to save bandwidth by only having people view a full post if they actually want to read it
  • You just like the "teaser" format

What's new in this release:

4.1.5:

  • Internalization requirement fix as requested by WordPress.

4.1.4:

  • Change default teaser template to be more WCAG compliance for accessibility.

4.1.3:

  • More compatibility fix for current WordPress release

4.1.2:

  • Minor bug fix
  • Compatibility fix for current WordPress release

4.1.1:

  • Fix Post Teaser ignoring Custom Field directive (disable or showall)

4.1.0:

  • Added "Advance tease control" feature that allows category or tag to turn off Post Teaser
  • Added option to disable tease or force fullpost on the homepage
  • Added option to move post statistic block from the bottom of the post to above the post text
  • Fix incompatibilities with "Search Unleashed" plugin The fix is tested in my test env, please report if issue is not resolved
  • Cleanup UI in Settings page
  • Misc bug fixes

Known issue(s):

  • Current translation files will not have translation for new options introduced in this release. Apologies to Non-English users of PostTeaser. This problem will exist and will break the translation files further in up coming release due to heavy remodeling the PostTeaser admin page. For translators, please help fix the language files.

Contributors:

**** NOTE: Use contact form for support request.

Translators:

Requires: 2.6 or higher
Compatible up to: 4.3.6
Last Updated: 1 year ago
Active Installs: 6,000+

Ratings

0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
60,5,3
50,6,3
57,7,4
80,5,4 100,1,1 100,2,2
100,2,2
100,7,7
100,1,1
100,2,2
0,1,0
100,1,1
0,1,0
100,1,1
100,1,1
0,1,0
0,1,0