This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

OSD Outdated Browser

Description

OSD Outdated Browser widget allows you to display a custom banner for users using old browsers.
The banner is fully customizable and also exposes filters for developers to use. All a user needs to do
is install/activate the plugin, set up the proper settings, then add the OSD Outdated Browser widget
to a widget area.

A Brief Feature List

  1. Fully customizable
  2. Filterable banner message using add_filter() for theme developers
  3. Easy to style
  4. Minimal Code
  5. No added load on your installation

Link to plugin page WordPress plugin page.

Screenshots

  • The default banner of OSD Outdated Browser
  • A slightly themed banner
  • Admin Settings Screen

Installation

  1. Upload the osd-outdated-browser directory to your /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Visit the settings page under Settings > OSD Outdated Browser
  4. Add the OSD Outdated Browser widget to any widget area in your theme.
  5. If the default message is not used, be sure to include an element with the id “osd-outdated-browser-close” in order to close the banner and set a cookie based on user preferences.
  6. Styles can be easily overridden in the theme’s style sheet (style.css) or in the WYSIWYG editor
  7. If you desire more control over how the banner is displayed, a WordPress filter is available. just use the following code: add_filter(‘osd-outdated-browser’, function($content, $args) {}, 10, 2);
  8. Additionally, the WordPress filters content_edit_pre and content_save_pre are applied to the banner content.

FAQ

Soon to come?

Yes, as users ask us questions.

Reviews

There are no reviews for this plugin.

Contributors & Developers

“OSD Outdated Browser” is open source software. The following people have contributed to this plugin.

Contributors

Translate “OSD Outdated Browser” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

1.5

  • Added settings link to plugins page

1.4

  • Fixed minor styling bug
  • Enabled use with a shortcode

1.3

  • Fixed a bug where older versions of PHP would not work.
  • Fixed a minor style issue
  • Updated instructions because they were terrible and mentioned nothing of being a widget

1.2

  • Fixed a style bug in IE.

1.1

  • Fixed a logic bug where javascripts and styles were being inserted regardless of the banner showing or not.

1.0

  • Initial creation of the OSD Outdated Browser