WordPress.org

Plugin Directory

MP3-jPlayer

Easy, Flexible Audio for WordPress.

Mobile friendly HTML5 audio players and audio playlist players

  • Flexible multi-player audio plugin.
  • Play from your library, uploaded folders, and urls.
  • Player style, colour, and layout options.
  • Popout players and popout links, audio widgets, and smooth audio downloads.
  • Works with all built-in WordPress options for adding your music, including the recently introduced Create Audio Playlist drag & drop interface.

Basic Demo - Showing the included player skins
How to Add Your Players
Help & Docs main page

MP3-jPlayer will expand WP's native shortcodes with new functions and options, giving you a lot of choice in how to set up your music playlists. Here's a few of the features:

  • Add unlimited music players to pages, posts, sidebars, and template files.
  • Offer downloads to visitors or logged-in users.
  • Playlist folders with one simple feed folder command.
  • Can be selectively integrated with WordPress default audio players.
  • Customise the colour scheme, fonts, title and image placements and more on the Player Design page.
  • A fully integrated Pop-out player that can be launched from playlist players, or from a stand-alone popout link.
  • Shortcode parameters to give you individual control of player heights, widths, volumes, downloads, styling, and allow you to play from your library, local folders or urls.
  • You can use custom fields to manage playlists.
  • Supports playback via HTML5 wherever possible, and falls back to Flash automatically if necessary.
  • Supports mp3, m4a, mp4, webm, oga, ogg, and wav files.
  • Very easy file counterparting, just upload.
  • Plays Icecast and Shoutcast audio streams.
  • Great compatibility across browsers / platforms. Works on iPhone, iPad, Android.
  • Editable player designs via CSS.
  • Multisite compatible.
  • Fully re-skinable.
  • Add-ons available such as stats collection.
  • Extensible plugin architecture and developer features.

See the plugin's home page for info, demos, documentation, and help articles.

Requires: 2.9 or higher
Compatible up to: 4.3
Last Updated: 2015-8-20
Active Installs: 20,000+

Ratings

4.2 out of 5 stars

Support

4 of 16 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1 50,2,1
100,1,1
100,1,1 100,2,2
100,1,1
86,7,6
0,2,0
50,2,1 100,1,1
100,1,1 100,2,2 50,4,2
100,1,1
83,6,5 100,2,2
60,20,12 50,2,1 58,24,14
67,12,8
68,28,19
67,3,2
0,1,0
67,9,6
60,5,3 100,1,1
0,5,0
100,2,2 50,2,1 75,4,3 67,6,4
100,2,2
100,3,3
50,2,1
67,3,2
50,2,1
100,1,1
50,2,1
100,1,1
50,2,1
100,1,1
100,1,1
0,1,0
100,1,1