This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Minimum Featured Image Size

Description

With this plugin you can set the minimum/exact width and height required for featured images used in standard and custom posts. You can also customise the error message shown to the user when an image isn’t large enough. Supports the Gutenberg Block Editor.

Screenshots

  • Plugin settings
  • Error message displayed to user if image isn't large enough

Installation

  • Upload minimum-featured-image-size folder to your /wp-content/plugins/ directory.
  • Activate the plugin through the ‘Plugins’ menu in WordPress.
  • Go to Settings > Minimum Featured Image Size.

FAQ

None yet!

Reviews

May 25, 2018
Great plugin, very useful. The only thing it lacks in my opinion is a max size option, or perhaps a single size - so that ONLY that size can be uploaded. Thanks!
February 16, 2018
Straightforward and well written plugin. Very handy to help enforce beautiful featured imagary on your clients sites.
January 6, 2018
very useful for a multi-author environment. It would be great to improve a little bit with the suggestions in the support forum or get an answer.
October 1, 2017
After spending weeks sourcing for a solution to fix the featured image problem for our team members continuously using small images, managed to find this plugin. Does the job perfectly. However, would appreciate if the system sends a notification warning when the user presses "Set Featured Image" and it is found that it is too small, rather than right before it is going to be published.
Read all 5 reviews

Contributors & Developers

“Minimum Featured Image Size” is open source software. The following people have contributed to this plugin.

Contributors

Changelog

0.1

  • Initial release

1.0

  • Use Ajax to check image size, post no longer has to be published to check image size
  • Add admin setting for error message
  • Add admin setting to disable Ajax
  • Improve UI for error messages displayed to the user

1.1

  • Add option to set image sizes for custom post types

1.1.1

  • Bug fix to resolve conflict with bbPress

1.1.2

  • Bug fix

2.0

  • Feature requests added – exact dimensions, choice of post disabling
  • Add Gutenberg Block Editor support

2.0.1

  • Bug fix