This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Known Plugin Dependencies

Description

The awesome WordPress Plugin Dependencies plugin introduces plugin dependency management right into your WordPress admin area.

Unfortunately, the reality is that very few plugins currently contain dependency information and until that changes, the effect of having the WordPress Plugin Dependencies plugin activated is minimal.

This plugin enriches the information about dependencies available to the Plugin Dependencies plugin bridging the gap until plugins catch up and start incorporating the Depends and Provides tags in their file headers properly.

You’ll need to have version 1.3 or higher of the WordPress Plugin Dependencies plugin installed for this plugin to have any effect.

Disclaimer:

The dependency list provided by this plugin is – and will always be – incomplete.

Additional information to be added to the list is very welcome and will be gracefully accepted.

Even better: send a pull request or bug report to your favorite add-on plugin requesting them to start using the tags.

Background

This plugin was inspired by this discussion.

Rather than having individual developers create their own lists to enrich the available information, this plugin tries to bundle the knowledge of dependencies.

The ultimate goal is for the Depends tag to be widely adopted and this plugin to become obsolete.

Of course, it would also help a lot if the Depends/Provides tags would be officially recognized and mentioned in the Plugin Developers FAQ and if what’s expected to be at the top of the main .php file would be as well documented as the readme.txt file in the Developer Center, but that’s a whole other challenge 😉

Any lobbying you can do for this will of course be encouraged and applauded!

If you like this plugin, please rate and/or review it. If you have ideas on how to make the plugin even better or if you have found any bugs, please report these in the Support Forum or in the GitHub repository.

Screenshots

  • Before: Plugins page with the Plugin Dependency plugin activated.
  • After: Plugins page with the Plugin Dependency plugin activated + Known Plugin Dependencies plugin activated.

Installation

  1. Extract the .zip file for this plugin and upload its contents to the /wp-content/plugins/ directory. Alternatively, you can install directly from the Plugin directory within your WordPress Install.
  2. Activate the plugin through the “Plugins” menu in WordPress.

FAQ

How to add dependency information to a plugin:

Add a ‘Depends:’ tag to the header of the main plugin .php file of plugin.

<?php
/**
 * Plugin name: My Plugin
 * Depends:     Another Plugin
 */

Sending in Git pull requests/ SVN change requests to plugins with known dependencies is the best way to ensure plugin inter-dependency information is known and I strongly encourage you to do so.

Reviews

Excellent!!

Thankyou so much for the plugin. I hope that you are shown more support, in any event I encourage you to continue the good work.

Read all 1 review

Contributors & Developers

“Known Plugin Dependencies” is open source software. The following people have contributed to this plugin.

Contributors

Changelog

0.1 (2014-09-20)

  • Initial release