k-OutDated Checker (k-OC)

Description

Scans automatically, twice a day, all of your installed plugins against the WordPress Plugin Directory for outdated plugins and email an alert for update.

What k-OutDated Checker (k-OC) Does

k-OC stands for k-OutDated Checker. k-OC scans automatically, twice a day, all your installed plugins against the WordPress Plugin Directory for outdated plugins and email an alert for immediate update.

History

k-OC got its start when I had to maintain a lot of WordPress installations which their owners didn’t care much about maintenance and security.

Included Languages

  • English (default)
  • Greek (el)

If you want to help out, I have included the .pot file in /language folder. You can send them to nbran@kanenas.net

Screenshots

  • This is how the email alert will look like if plugins are not up-to-date.

Installation

After downloading and extracting the latest version of k-OC:

  1. Upload the folder k-outdated-plugin-checker-k-opc to the /wp-content/plugins/ directory.
  2. Activate the plugin through the ‘Plugins’ menu in WordPress.
  3. That’s all!

FAQ

I have activated the plugin. Now what?
  • You don’t have to do anything else! k-OutDated Checker will scan all your plugins against the WordPress Plugin Directory (twice a day) and alert the administrator of your website (by email) if at least one plugin is outdated.

Reviews

December 24, 2018
Just install and it's ready! Does what it's supposed to do with zero effort.
November 20, 2018
Sends an e-mail saying that there's an update available for every single one of our website's installed plugins, including k-OutDated Checker (k-OC) itself. There are currently NO updates available for ANY of our website's installed plugins. In summary: this plugin cannot correctly determine whether *itself* is up to date. Uninstalling.
Read all 2 reviews

Contributors & Developers

“k-OutDated Checker (k-OC)” is open source software. The following people have contributed to this plugin.

Contributors

“k-OutDated Checker (k-OC)” has been translated into 1 locale. Thank you to the translators for their contributions.

Translate “k-OutDated Checker (k-OC)” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

1.2.3 08/02/2018

  • ENHANCEMENT: Changed how the version of the plugins is checked against the WordPress Plugin Directory.
  • NEW: Show next to current the new version of the plugin that needs update.
  • Update the “Tested up to” in readme.txt.

1.2.1.1 10/10/2017

  • NEW: Added “Minimum PHP Version Requirement” in readme.txt.
  • Update the “Tested up to” in readme.txt.

1.2.1 17/09/2015

  • NEW: Added the k-outdated-plugin-checker-k-opc.pot file in languages folder.
  • NEW: Added translation for Greek.

1.2 17/09/2015

  • ENHANCEMENT: Internationalizing the plugin (accepting translations).
  • ENHANCEMENT: Implementation of WordPress “PHP Coding Standards” (https://make.wordpress.org/core/handbook/best-practices/coding-standards/php/).

1.1 05/05/2015

  • FIX: Check only for plugins that exist in WordPress Plugin Directory.
  • FIX: Send email alert only when at least one plugin is outdated.

1.0 (First Release) 04/05/2015

  • This is the initial release of k-OC.