Include Me

Description

Include Me helps to include in posts or pages external files usually to be shared
between different posts or pages or that contains PHP or other code that can be
compromised by the visual editor.

The use is immediate: the shortcode [includeme] is all that you need (see the documentation
on Include Me official page).

The best way to use it is to include functionalities
written in external PHP that will be rendered in post body or to include pieces of
javascript that will be hard to add with WordPress editor.

Inclusions can be rendered with IFRAME if needed to create boxes that display
external web pages.

This plugin is made of few line of code, ultralite!

Other plugins by Stefano Lissa:

FAQ

No questions have been asked.

Installation Instructions
  1. Put the plugin folder into [wordpress_dir]/wp-content/plugins/
  2. Go into the WordPress admin interface and activate the plugin
  3. There is no option page, please consult the official plugin page for usage

Reviews

Awesome… but PHP caveat

Does just what I want; including a snippet of my PHP directly, without the formatting-sizing problems of an <iframe>.

One issue:

If you include like this: [includeme file=”myscript.php”]

… any variables in your script defined outside of a function will NOT be automatically global, like they normally would. This took a lot of figuring out, but you must such variables as global so they can be accessed within functions.

Excellent Include Functionality

This plugin works great to include simple .php pages I’ve written outside of WordPress. For example, I wrote a .php page to query temperature sensors on my network. The Include Me plugin lets me display that .php page in a WordPress page. Awesome!

Read all 8 reviews

Contributors & Developers

“Include Me” is open source software. The following people have contributed to this plugin.

Contributors

Changelog

1.1.5

  • Added support for inclusion of a post/page content

1.1.4

  • Fixed a link

1.1.3

  • Added usage search in posts and pages

1.1.2

  • WP 4.4.2 compatibility check
  • Fixed few texts

1.1.1

  • Added translation code

1.1.0

  • Fixes

1.0.9

  • Compatibility check for WP 4.0
  • readme.txt fix

1.0.8

  • Compatibility check

1.0.7

  • Performce improvements

1.0.6

  • Improvements

1.0.5

  • Added short codes execution feature on included content (by Rusty Eddy)

1.0.4

  • Administrative styles and header