Plugin Directory

!This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

HS Membership Plugin

Addon plugin to s2Member. Additional functionality for Multi-Site Installations. s2Member 3.1.2 required.

HS Membership plugin add onto the already extensive s2Member. It provides additional functionality including:

  • The ability to disable the creation of blogs for Multi-Site installations, based on Membership Level.
  • New redirect to a 'Login Required' page, to promt the user to login first before he can browse the contents of the blog. This is required for older installs and upgrades from WPMU 2.9.
  • New meta-box feature added to allow the author to set the Access Level of a Page/Post directly from the edit page.

This plugin requires the following to ensure full functionality:

  • WordPress Multi-Site: 3.0.0, tested up to 3.2.1
  • s2Member: 3.1.2, tested up to 110815

Requires: 3.0.0 or higher
Compatible up to: 3.2.1
Last Updated: 2013-6-5
Active Installs: 80+


0 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 50,2,1