Plugin Directory

Test out the new Plugin Directory and let us know what you think.

Google Webfonts For Woo Framework

Give the WooThemes framework access to the full range of current Google Webfonts.

The purpose of this plugin is to make all available Google webfonts available to the WooThemes Canvas theme, and any other themes that use the WooThemes framework. It also allows additional selected international subsets (Greek, Cyrillic, Vietnamese etc.) to loaded, which the Woo Framework does not support at present.

It works like this:

  1. You install the plugin. It contains a key that is used to access the Google Webfonts API.
  2. The API is used to download the full list of Google web fonts in the Settings page. This is cached locally, and will only be refreshed when you save the plugin settings page.
  3. The full list of fonts and all variants replaces the list that the Woo framework defines internally.

What you should then see, is the ability to select any available Google web font in the WooThemes theme administration pages, and have those fonts displayed in your theme.

In previous versions, you had to register for a Google API key. You no longer have to do this, as the plugin has a shared API key built-in. You can still use your own, but if you don't, then the shared key will be set when activating the plugin.

If an invalid API key is used, this plugin has a fallback list of fonts, so you can try it out without an API key, and that might even be good enough for your purposes.

In addition, you can select the weights that will be downloaded. If you only use light/regular/bold (300/400/700) then there is no point requesting all the additional weights from some of the fonts that are more complete, but consequently are a very heavy download. This plugin will help to keep the bandwidth down, and so the load speed higher.

This plugin has been tested against PHP5.3 and the project repository is here:


Changes have been made so that it works with PHP5.2 and has been reported as working. However, I work under at least 5.3 so some incompatibilities may creep in by accident from time-to-time - just report them and I will do my best to fix as quickly as possible.

Please let me know how this plugin works for you, whether you like it, and how it can be improved.

Requires: 3.3 or higher
Compatible up to: 4.2.12
Last Updated: 1 year ago
Active Installs: 2,000+


5 out of 5 stars


Got something to say? Need help?


Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1 100,1,1