WordPress.org

Plugin Directory

Global Translator

Automatically translates your blog in 63 different languages!

Global Translator can automatically translate your blog in the following 63 different languages: Afrikaans, Albanian, Arabian, Armenian, Azeri, Basque, Belarusian, Bosnian, Bulgarian, Catalan, Croatian, Czech, Chinese, Danish, Dutch, English, Estonian, Finnish, French, Galician, Georgian, German, Greek, Haitian (Creole), Hebrew, Hungarian, Icelandic, Indonesian, Irish, Italian, Japanese, Kazakh, Korean, Kyrgyz, Latin, Latvian, Lithuanian, Macedonian, Malagasy, Malay, Maltese, Mongolian, Norwegian, Persian, Polish, Portuguese, Romanian, Russian, Spanish, Serbian, Slovak, Slovenian, Swahili, Swedish, Tagalog, Tajik, Tatar, Thai, Turkish, Uzbek, Ukrainian, Vietnamese, Welsh.

Main features:

  • A NEW translation engine: it uses the Yandex Translate APIs, which provide a very high and proven quality on its translation.
  • Easy to configure: You just need to choose the translations to enable and to register your Yandex API keys and the plugin will automagically start translating your website!.
  • Search Engine Optimized: it uses the permalinks by adding the language code at the beginning of all your URI. For example the english version on http://www.domain.com/mycategory/mypost will be automatically transformed in http://www.domain.com/en/mycategory/mypost. It also automatically adds the "hfrelang" tags to your pages telling Google that it can serve that page to users searching in that language.
  • Fast Caching System: new fast, smart, optimized, self-cleaning and built-in caching system.

Global Translator is the first real (and free) traffic booster for your blog! It can help you to reach a lot of new users and consequently to strongly increase your popularity: if you derive some benefits and if you want to support the development, please consider to support it with a donation.

Requires: 3.6 or higher
Compatible up to: 4.4.*
Last Updated: 1 month ago
Active Installs: 10,000+

Ratings

3.3 out of 5 stars

Support

0 of 4 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0
20,5,1 100,1,1 100,1,1 0,1,0
33,3,1 67,3,2 100,1,1 100,1,1
33,6,2 50,2,1 60,5,3 67,3,2 100,1,1
67,9,6 74,19,14 100,1,1
50,6,3 0,1,0
0,1,0 46,26,12
50,2,1
0,2,0
100,2,2
14,7,1
0,1,0
0,1,0 0,1,0 0,1,0 0,1,0 0,1,0 0,1,0 0,1,0 0,1,0 0,1,0 33,3,1
0,1,0
21,14,3
0,4,0
14,14,2
25,4,1
50,2,1
100,2,2
33,3,1
50,2,1
0,1,0
100,1,1
100,1,1 0,1,0