This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

This plugin has been closed and is no longer available for download.

GD Simple Widgets

Description

This plugin contains powerful widgets with simple options to set. Some of them are based on standard WordPress widgets but with extended options and rendering. You can also disable default WordPress widgets if you choose to use Simple Widgets versions.

Supported languages: english, serbian, spanish, danish, chinese, korean, polish

Plugin Home |
Support Forum |
Feedburner |
Twitter |
Facebook Page

Screenshots

  • Main settings panel
  • Recent Comments widget
  • Posts Authors widget
  • Popular Posts widget

Installation

  • Upload folder gd-simple-widgets to the /wp-content/plugins/ directory
  • Activate the plugin through the ‘Plugins’ menu in WordPress
  • Main settings panel is iin the Settings menu or in GD Press Tools menu (if this plugin is installed)
  • Activated widgets on the settings panel will be visible on widgets panel

Requirements

  • PHP: 5.0 or newer
  • mySQL: 5.0 or newer
  • WordPress: 3.0 or newer

Widgets

  • gdWS Popular Posts widget requires GD Press Tools 2.0.0 or later.

FAQ

Does plugin works with WPMU and WordPress MultiSite installations?

Yes.

I want to translate the plugin to my language, or to improve existing translations?

You only need POEdit program that works on Windows, Linux and MacOS. Instructions on how to make or update translations are here: http://dv4p.com/wa.

Contributors & Developers

“GD Simple Widgets” is open source software. The following people have contributed to this plugin.

Contributors

Translate “GD Simple Widgets” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

1.7

  • Compatibility with WordPress 3.6
  • Proper use of enqueue files functions
  • Improved and cleaned plugin code
  • Improved widgets loading and initialization
  • Improved rendering for some widgets
  • Dropped support for WordPress 2.8 and 2.9

1.6.5

  • Compatibility with WordPress 3.3
  • Using capability for the plugin menu
  • Removed obsolete update notification code
  • Several minor updates

1.6.0

  • Some minor code cleanup and updates
  • Fixed problem with category filters for some widgets

1.5.9

  • Fixed invalid author link for the authors widget

1.5.8

  • Small updates
  • Number of bugs fixed

1.5.7

  • Changed default post widget rendering
  • Small changes for WP 2.9

1.5.6

  • Several bugs fixed

1.5.5

  • Pre-caching of data to minimize the number of queries
  • Added chinese translation
  • Added korean translation

1.5.4

  • Updated basic widget class and forms loading
  • Fixed missing or invalid CSS classes
  • Fixed problem with non-standard users database table location

1.5.3

  • Filters for modifying data and widget sql queries
  • Improved basic widget class

1.5.2

  • Updated gdragon shared libraries
  • Minor updates and changes

1.5.1

  • Minor initialization problems

1.5.0

  • New widget with two 125×125 ads