WordPress.org

Plugin Directory

FooThumbnail Gallery

The absolute easiest way to launch a gallery in FooBox from a Thumbnail. Ever.

An easy way to display your WordPress galleries from a thumbnail image with FooBox.

NOTE: FooBox Free or Pro is REQUIRED for this plugin to work.

FULL DETAILS: For more information and resources on FooThumbnails for Galleries, visit foothumbnails.mattcromwell.com.

FooThumbnails for Galleries is designed to be the easiest way to create a Gallery that can be launched from a Thumbnail image using FooBox. With an intuitive creation "wizard", options to select your thumbnail size, text wrapping, and 7 different layout including creating your own custom layout, you have all the options you need.

Why would you want to do that? Actually, it's a really great way to have your gallery be totally responsive and social-shareable (with FooBox), while limiting the space it takes in your post. You can keep telling your story, and point folks to the gallery. FooBox supports captions so your gallery can tell a nice sub-story along the way. Here you'll find a nice demo: http://foothumbnails.mattcromwell.com/demo

Features

  • Supports both FooBox Free and FooBox Pro without you having to add any special code at all.
  • You can choose from any registered image size your theme supports for your thumbnail image.
  • Creation "Wizard" that walks you through the Gallery process step by step
  • Simple shortcode usage, no need to remember crazy attributes
  • "Left", "Right", and "None" for text-wrapping options
  • 6 Layouts
  • Customize the static layouts per gallery with a custom CSS field
  • Or create your own custom FooThumbnail Gallery template to put in your theme!

Coming Soon

  • Upgrade the Gallery insertion field to make it even simpler.
  • Language support (German, Spanish). Click here if you'd like to contribute a translation.
  • Support multiple Custom Templates
  • Thumbnail Image effects
  • Thumbnail Border Styles and Shapes

Special Thanks to the Beta Testers

  • Big shout out to the "FooDudes" Adam Warner and Brad Vincent for supporting this and giving me valuable feedback.
  • Another big shout all these beta testers as well: Lucy Beer, Michael Beil, Stephen Carnam, Yaron Guez, Dave Jesch, Leon Magee, Phelan Riessen, Ry Satterfield, Heather Baker Steele, Ansel Taft, and Devin Walker

Requires: 3.5.1 or higher
Compatible up to: 4.0.7
Last Updated: 2014-9-4
Active Installs: 100+

Ratings

4.6 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,2,2 100,1,1
100,1,1