WordPress.org

Plugin Directory

Test out the new Plugin Directory and let us know what you think.

Expire Passwords

Require certain users to change their passwords on a regular basis.

Did you find this plugin helpful? Please consider leaving a 5-star review.

Harden the security of your site by preventing unauthorized access to stale user accounts.

This plugin is also ideal for sites needing to meet certain industry security compliances - such as government, banking or healthcare.

In the plugin settings you can set the maximum number of days users are allowed to use the same password (90 days by default), as well as which user roles will be required to reset their passwords regularly (non-Administrators by default).

Languages supported:

  • English
  • Czech
  • EspaƱol

Development of this plugin is done on GitHub. Pull requests welcome. Please see issues reported there before going to the plugin forum.

Requires: 4.0 or higher
Compatible up to: 4.7.1
Last Updated: 2 weeks ago
Active Installs: 400+

Ratings

4.9 out of 5 stars

Support

1 of 1 support threads in the last two months have been marked resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1 100,1,1 100,1,1