WordPress.org

Plugin Directory

EU Cookie Law

EU Cookie Law informs users that your site uses cookies, with option to lock scripts before consent. Light + Customizable style.

EU Cookie Law is a light, elegant and powerful solution that allows your website to comply the european cookie law by informing users that your site has cookies, with a popup for more information and option to lock scripts before acceptance (as required by Italian Law - Garante della Privacy dispositions).

You can customise the style to perfectly fit your website and you have many options to control cookies behaviour after and before acceptance.

Demo: http://www.sanpellegrinoterme.gov.it

Features

  • Customizable banner
  • (option) Consent by Scrolling
  • (option) Consent by Navigation
  • Set cookie expiry
  • Fully responsive for tablets and smartphones
  • Set banner position
  • Compatible with mobile themes and plugins
  • Compatible with multilanguage plugins
  • Certified for WPML
  • 2-layer cookie prevention
  • **Cookie Control" shortcode to easily revoke cookie consent
  • **Cookie List" shortcode to show a list of active cookies
  • Compatible with Disqus

Advanced Features

  • Block scripts if cookies are not accepted
  • Automatic block of iframes, embeds, scripts and objects
  • Complete set of developer Shortcodes and PHP Functions
  • Manual and Automatic set width and height of blocked content

Simply install the plugin and follow the instructions on the Settings page.

Cookie block

You can lock cookies using [cookie] and [/cookie] shortcodes in every post, page and widget. You can use php functions too:

if ( function_exists('cookie_accepted') && cookie_accepted() ) {
    // Your code
}

More Shortcodes & PHP Functions are available in our faqs.

EU Cookie Law started from Peadig in 2012 and in june 2015 has became part of WPGov.it that aims to give Italian Public Government powerful open source solutions for websites.

Included Languages

If you want to help out, we have included the .pot file in /language folder. You can send them to milesimarco@outlook.com

Contributions

Requires: 3.8 or higher
Compatible up to: 4.3
Last Updated: 2015-8-26
Active Installs: 10,000+

Ratings

4.5 out of 5 stars

Support

13 of 25 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

67,3,2
100,1,1 50,2,1
100,3,3
100,1,1 100,1,1 100,2,2 100,1,1 100,1,1 100,1,1 100,1,1 50,2,1 100,2,2 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,2,2
100,1,1 100,1,1 100,1,1