This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

EDD Versions

Description

When using the Easy Digital Downloads plugin to create an online store that sells digital downloads, this plugin will allow you to attach a version number to each of your products.

NOTE: This plugin requires Easy Digital Downloads v1.3+

What does this plugin do, exactly?

This is a simple plugin that essentially does two things.

  1. Adds a “Version” field to the EDD’s “Download Configuration” meta box.
  2. Adds the inputted version to the Download History table outputted from EDD’s [download_history] shortcode.

What about the EDD Software Licensing addon?

To avoid redunancy, if you’re using the EDD Software Licensing addon, which already allows you to input a version number, this EDD Versions plugin will not add its “Version” field. And instead, your version number setup with the EDD Software Licensing addon will get used in the table outputted with [download_history].

Screenshots

  • Version field added to EDD's "Download Configuration" meta box.
  • Version added to the [download_history] shortcode's outputted table.

Installation

  1. Upload edd-versions folder to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. After activating this plugin, there will be a “Version” field added to the main “Download Configuration” meta box when configuring a downloadable product of Easy Digital Downloads.

Note: If you’re using the EDD Software Licensing addon, our plugin’s “Version” field will not be displayed, and instead, the version number you setup with EDD Software Licensing addon will be used.

Contributors & Developers

“EDD Versions” is open source software. The following people have contributed to this plugin.

Contributors

Changelog

1.0.1

  • Adjusted plugin to check for EDD_Software_Licensing class to avoid conflicts with other EDD addons that may be using the EDD_SL_Plugin_Updater class.

1.0.0

  • This is the first release.