WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Dbox 3D Slider Lite

Embed 3D Responsive Slider of Media Library Images, Recent Posts, Category Posts, Custom Post Type

Looking for a responsive 3D slideshow plugin? Dbox Slider Lite is the perfect solution for that. It can create and embed a 3D slider with smooth transitions and powerful controls in no time. You can easily attach WordPress media library images to the slider and embed the same anywhere on site using any of the following methods,

  • Shortcodes
  • Widgets
  • Template Tags

Take a look at the features of Dbox Lite,

Front-end Features

  • 100% Responsive Design
  • Multiple 3D Transitions – Horizontal, Vertical or Random
  • Embed Self Hosted, YouTube, Vimeo Videos
  • Meta Information including Author Name, Published Date
  • Show/Hide Meta Information
  • Auto Play/Pause Button
  • Keyboard Navigation
  • Touch Swipe Support for Touch Screen Devices
  • Responsive Design. Works great on iPhone, Android and other Smartphones
  • SEO Ready and Search Engine Friendly

Demo

Back-end Features

  • Control 3D Transitions – Horizontal, Vertical and Random
  • Live Preview of Slider on Settings Panel
  • Define Number of Cubes for Split Design
  • Define gap between the Cubes
  • Use Google Fonts for Text
  • Choose to load different formats of Images from media library
  • Customize the background of slider Title, Content and Meta Information
  • Enter Custom CSS on Settings Panel, No need to edit theme’s style.css
  • Taxonomy Add-on Compatible
  • Post Attachments Add-on Compatible

Premium Version

Dbox Slider PRO offers some premium features:

  • Create Unlimited Setting Sets
  • Create Unlimited Sliders
  • Link Slides to External URLs, Banners
  • Minimize Text on Load
  • Lightbox Effect
  • Define Perspective for 3D Transitions
  • Set Distance Between Rotating Cubes
  • Unlocked Meta Field Boxes, Edit as per your Choice
  • Editable Meta Field Boxes
  • More Meta Fields
  • Export/Import Settings
  • NextGen Gallery Add-on Compatible
  • RSS Feed Add-on Compatible

Requires: 3.5 or higher
Compatible up to: 4.1.1
Last Updated: 2015-2-27
Active Installs: 600+

Ratings

5 out of 5 stars

Support

1 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
0,1,0