WordPress.org

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

WP Composer

Adding Composer dependency management to WP CLI.

Adding Composer dependency management to WP CLI. Allows you to recursivly install/update composer packages inside of all of your WordPress plugins and themes.

What is this using?

This package uses a great piece of software called WP-CLI. It provides a command line interface for WordPress management. We are a plugin providing Composer management inside of WP CLI.

What's Composer?

It's the greatest thing to happen to the web since GIFs, Drop Shadows and dancing cats. Composer is a dead simple JSON-based dependency manager for PHP. For more information, check out http://getcomposer.org/.

So this is complete Composer support?

No, not exactly! Sadly, I'm building this out and I'm trying to make some sweet WP-CLI and Composer integration. But for now, we only support a few command:

  • install
  • update
  • diagnose
  • help
  • status

If you'd love to help out, please help! Make a pull request and let's get coding!

How do I build Composer Management inside of my plugin?

Simple really! You just create a simple composer.json file like you would with any Composer project. From there, wp-composer will interface with each plugin/theme that has composer support and it will generate the autoload files, too!

Just include something like this inside your main plugin file:

require(__DIR__.'/vendor/autoload.php');

It's that simple.

Requires: 3.3 or higher
Compatible up to: 3.5.2
Last Updated: 2013-6-16
Active Installs: 400+

Ratings

5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1