This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

CF7 Required custom field

Description

The CF7 is one of the most used wordpress plugins. The number of installations is more than 5 million now. This plugin gives you great opportunity for setting up forms, but at some points its functionality is limited. For example, it is not possible to specify different error messages for mandatory fields.
The “CF7 Required custom field” plugin provides this opportunity. After formatting the form template, all mandatory fields are appeared in the “Custom required field message” tab and user is able to specify a unique message for each individual field.
The plugin supports all CF7 form-tags: text*, email*, url*, tel*, number*, date*, select*, checkbox*, file*, textarea*.
If you want to show a standard message, you just leave the field blank.

CF7 Required custom field Features

  • The plugin gives you the ability to set user messages for required input fields
  • The plugin allows you to set validation messages for all required input fields.
  • Custom messages of text, email, URL, date, tel, number, drop-down menu, checkboxes, file and textarea fields.

Plugin Requirement

PHP version : 5.3 and latest
WordPress : WordPress 4.5.4 and latest

Screenshots

  • Screenshot 'screenshot-1.png' shows tab plugin settings.
  • Screenshot 'screenshot-2.png' shows fields for entering a unique message.
  • Screenshot 'screenshot-3.png' shows front part, required fields where a custom message is specified and by default.

Installation

  1. Upload the entire cf7-required-custom-field folder to the /wp-content/plugins/ directory.
  2. Activate the plugin through the ‘Plugins’ menu in WordPress.

FAQ

Installation Instructions
  1. Upload the entire cf7-required-custom-field folder to the /wp-content/plugins/ directory.
  2. Activate the plugin through the ‘Plugins’ menu in WordPress.
How to show a standard message for the required field?

Just leave the message field blank.

Reviews

July 19, 2018
Great plugin which did exactly what I needed - now I can customize error messages without any coding! Thank you for your work!!!
Read all 1 review

Contributors & Developers

“CF7 Required custom field” is open source software. The following people have contributed to this plugin.

Contributors

Changelog

1.0

  • Initial Release – 05.06.2018

1.0.1

  • Initial Release – 05.06.2018

  • Compatibility check with latest versions of wordpress.

1.1

  • Initial Release – 07.06.2018

  • added Russian localization ru_RU.

  • name changes ECRMT_EditorPanelSerror on ECRMT_EditorPanelsError.
  • add method ecrmtLoadPluginTextdomain.