This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

This plugin has been closed and is no longer available for download.

Campaign Press

Description

Campaign Press makes it easy to gather sign ups and manage your Campaign Monitor clients through WordPress. Campaign Press is in no way affiliated with Campaign Monitor.

For more information, please visit http://floatingmonk.co.nz/campaignpress/.

Add-Ons

Visit http://floatingmonk.co.nz/campaignpress/ to buy & download add-ons.

Installation

  1. Extract the zip and upload the entire campaign-press directory to the /wp-content/plugins/ directory.
  2. Activate the plugin through the Plugins menu in WordPress.

FAQ

Where can I find more information on Campaign Press

Visit http://floatingmonk.co.nz/campaignpress/ for answers to all your questions.

Contributors & Developers

“Campaign Press” is open source software. The following people have contributed to this plugin.

Contributors

Translate “Campaign Press” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

1.0.5

  • Fixed a bug which would stop required tables from being created in the DB (many thanks to RKB on the forums for his help on this one)
  • Fixed a bug where choosing a timezone with an ampersand in it would cause a validation error on sign up.
  • Changed the way that addons are included in Campaign Press due to some users having issues with the previous method.

1.0.4

  • Added descriptive error messages for when the plugin doesn’t activate.
  • Fixed a bug where an array_filter warning would be generated in some circumstances.
  • Fixed a bug where running a Sync would always create at least one new group if you pay on behalf of at least one client.

1.0.3

  • Fixed a bug where approving accounts would cause an error in some cases
  • Added the ability for password encryption without the mcrypt PHP module – so it’s no longer required

1.0.2

  • Fixed a bug that meant the plugin wouldn’t activate when running PHP versions older than 5.3.0 (to do with calling static methods).
  • Fixed a bug that meant that you couldn’t create groups (which meant without the sync plugin you couldn’t gather sign ups)

1.0.1

  • Bug fixes

1.0.0

  • Initial release