WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Better WordPress reCAPTCHA (support Akismet and Contact Form 7)

This plugin utilizes Google reCAPTCHA to help your blog stay clear of spams. You can use this plugin with Akismet and Contact Form 7.

In the 21th century, spamming could be one of the most annoying problems for a website. Especially if you use some publishing platforms like WordPress, your blog WILL be spammed and no default methods will save you from such nightmare. This plugin utilizes the popular anti-spam library, Google reCAPTCHA, to help your blog stay clear of spams.

Akismet and Contact Form 7 are supported out of the box.

Useful resources:

How-to: Add BWP reCAPTCHA to Contact Form 7.

How-to: Add custom translations to reCAPTCHA.

Official Documentation.

Some Features

  • You can add captcha to comment form, user registration form, site registration form and login form
  • You can add captcha to form generated by Contact Form 7 plugin: use recaptcha or bwp-recaptcha shortcode tag
  • Hide reCAPTCHA for qualified visitors
    • Registered Users (even with no capabilities needed)
    • Authorized Users (users who have some capabilities, you can extend the default list)
    • Visitors who have at least a required number of approved comments
  • Comment Form:
    • You can position captcha before or after the comment field (new in 1.1.1)
    • Control how the plugin reacts when captcha response is invalid
    • Set error message when captcha response is invalid
  • Theme Features:
    • Choose between 4 default themes or create your own (sample CSS and images provided)
    • Use built-in languages or add custom translations.
  • Integrate with Akismet for better end-users experience, i.e. "only force a CAPTCHA when a comment looks like spam".
  • WordPress Multi-site compatible: you can set different key pair for each site or use a single key pair for all sites
  • And more...

Please don't forget to rate this plugin 5 shining stars if you like it, thanks!

Get in touch

Languages

Please help translate this plugin!

Requires: 3.0 or higher
Compatible up to: 3.9.2
Last Updated: 2014-7-18
Active Installs: 20,000+

Ratings

4.4 out of 5 stars

Support

0 of 5 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
2 people say it's broken.

100,1,1
100,1,1
100,2,2
100,1,1
100,1,1
100,2,2 100,4,4
40,5,2
100,4,4
100,3,3
100,2,2
100,2,2
100,1,1
0,5,0 67,3,2
100,4,4
100,4,4 100,1,1 100,1,1 100,1,1
33,3,1
100,1,1
100,1,1
0,2,0