WordPress.org

Plugin Directory

Breadcrumb NavXT

Adds breadcrumb navigation showing the visitor's path to their current location.

Breadcrumb NavXT, the successor to the popular WordPress plugin Breadcrumb Navigation XT, was written from the ground up to be better than its ancestor. This plugin generates locational breadcrumb trails for your WordPress powered blog or website. These breadcrumb trails are highly customizable to suit the needs of just about any website running WordPress. The Administrative interface makes setting options easy, while a direct class access is available for theme developers and more adventurous users.

PHP Requirements

Breadcrumb NavXT 5.2 and newer require PHP5.3 Breadcrumb NavXT 5.1.1 and older require PHP5.2

Features (non-exhaustive)

  • RDFa compatible breadcrumb generation.
  • Extensive breadcrumb customization control via a settings page with appropriate default values for most use cases.
  • Network admin settings page for managing breadcrumb settings for all subsites with configurable global priority.
  • Built in WordPress Widget.
  • Extensible via OOP and provided actions and filters.
  • WPML compatible (enhanced compatibility with WPML extensions plugin).
  • bbPress compatible (enhanced compatibility with bbPress extension plugin).

Translations

Breadcrumb NavXT distributes with translations for the following languages:

  • English - default -
  • Russian by Alexander Samsonov
  • Catalan by Christian Eduardo
  • German by Daniel Lang
  • French (France) by Emmanuel Beziat, Erwan Lescop, and Serge Rauber
  • Czech by jakubmachala
  • Norwegian (Bokmål) by Jan Rosvoldsve
  • Danish by Joachim Jensen
  • Lithuanian by Johannes Rau
  • Spanish (Spain) by Karin Sequen
  • Portuguese (Portugal) by Luís Rodrigues
  • Estonian by Martin Orn
  • Swedish by Patrik Spathon
  • Dutch by Renée Klein
  • Italian by Tamara Balestri
  • Finnish by Ville Pilvio
  • Chinese (China) by Amos Lee

Don't see your language on the list? Stop by Breadcrumb NavXT's translation project.

Requires: 3.9 or higher
Compatible up to: 4.2.2
Last Updated: 2015-5-25
Active Installs: 300,000+

Ratings

4.7 out of 5 stars

Support

7 of 32 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

2 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
100,1,1 100,1,1 100,2,2
100,3,3 100,2,2 100,1,1
100,2,2 100,2,2 100,3,3 0,1,0 0,1,0
100,1,1 43,7,3 100,9,9 100,1,1 100,1,1
90,10,9 100,1,1 100,2,2
0,1,0 89,18,16 100,1,1 100,3,3 0,2,0
100,1,1 73,11,8 100,2,2
80,5,4 84,19,16 100,3,3
100,3,3 67,9,6
100,1,1 100,4,4
100,10,10 0,1,0
100,2,2 100,2,2
89,9,8 75,4,3 62,13,8 100,1,1 100,1,1 100,1,1 100,1,1
100,5,5
100,5,5 100,2,2
100,2,2 100,3,3 100,1,1
100,1,1 100,1,1
33,3,1
100,1,1 88,25,22 50,2,1 100,1,1 0,1,0
100,4,4 31,13,4 100,1,1 100,2,2 100,2,2
100,17,17 100,21,21
100,9,9 80,5,4
100,5,5
100,13,13 100,1,1 0,1,0
100,3,3 100,16,16 100,1,1
100,12,12 100,2,2 100,1,1
100,1,1 100,1,1 86,22,19 100,1,1 100,1,1
100,7,7
100,4,4
100,3,3
100,1,1 100,1,1
100,3,3 50,10,5 100,1,1
67,3,2 100,3,3
100,4,4
100,1,1
100,2,2
100,4,4
100,2,2 100,7,7 100,2,2
100,2,2
100,1,1 100,7,7
100,1,1 33,3,1
100,2,2 80,5,4
100,3,3
100,1,1
100,1,1
100,1,1
50,2,1 100,2,2