BP Distance Search

Description

BP Distance Search adds a new Google Place Autocomplete field type to your BuddyPress extended profiles.

You can then add the Google Place Autocomplete fields to your BP Profile Search forms, selecting either the distance search mode or one of the usual text search modes contains, is, or is like.

This plugin has been written mainly as a reference implementation for those plugins that add a location field type to the BuddyPress profiles, and wish to make it available for a search by distance in BP Profile Search forms.

That means that BP Distance Search will work as described, will be supported and maintained, but most likely won’t be extended with new features. In other words, I’m not planning to write another Google maps plugin, I only wish to offer the search by distance to the many users who ask for it.

Requires at least BuddyPress 2.4 — Tested up to BuddyPress 4.3.0

Installation

You’ll need a Maps JavaScript API key and you’ll have to enable the Geocoding API and the Places API.

This plugin doesn’t require any configuration, you’ll need your Google API key when you create a Google Place Autocomplete profile field.

Reviews

Simple to use and effective

As simple as installing the plugin, adding the field and API key. Perfect. Another exceptional plugin by Andrea. Thank you so much for your continued development of this plugin and BP Profile Search.
Read all 2 reviews

Contributors & Developers

“BP Distance Search” is open source software. The following people have contributed to this plugin.

Contributors

“BP Distance Search” has been translated into 1 locale. Thank you to the translators for their contributions.

Translate “BP Distance Search” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

1.1

  • Added location pin to get the current location

1.0.3

  • Fixed bug in back-end profile editing

1.0.2

  • Fixed conflict with the BuddyPress Date Selector field type

1.0.1

  • Added call to load_plugin_textdomain

1.0

  • Initial version released to the WordPress Plugin Directory