This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Bootstrap Swipe Gallery

Description

  • Must have Twitter Bootstrap 3 with Glyphicons.
  • Click on a gallery image and swipe through the pop-up.
  • Images re-size for mobile devices.
  • Option to create pop-ups of all post and page images.
  • Light: Only sends 3 small files to the browser. Does nothing if there’s no gallery.
  • Works with themes “DevDmBootstrap3,” “evolve,” and “Unite.”
  • Doesn’t work with “Customizr,” “Inkzine,” and “Radiant.”
  • Doesn’t change the gallery on your page. Only creates a pop-up when you click.
  • Don’t download if you need to be sure this works. This plugin is fast beacuse it uses your Glyphicons. You’ll see if it works when you activate it and click on a gallery image, though.

Screenshots

  • Mobile screen, with swipe support.
  • Tablet screen. Images keep their dimensions.
  • Fills most of a desktop screen.
  • Pop-up stays the same size, no matter what image is showing. Click in the same place to go to the next image.

Installation

  1. Upload the bootstrap-swipe-gallery directory to your /wp-content/plugins directory.
  2. In the “Plugins” menu, find “Bootstrap Swipe Gallery,” and click “Activate.”
  3. Click “Settings.”

FAQ

What does this require?

Twitter Bootstrap 3 with Glyphicons, and WordPress 3.9.

How do I create a pop-up?

Create a gallery in a post or page. Click “New Post,” “Add Media,” and “Create Gallery.”

Contributors & Developers

“Bootstrap Swipe Gallery” is open source software. The following people have contributed to this plugin.

Contributors

Changelog

1.0.4

  • Stability fix: only 20 images allowed in each pop-up.

1.0.3

  • Bug fix: images used to appear out of order.

1.0.2

  • Popup added for page images, if user’s options allow.

1.0.1

  • Fixed a bug where only one image would show.
  • Added an option to make a pop-up of all images in post, not just galleries.

1.0.0

  • First version