This plugin hasn’t been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Advanced Dewplayer

Description

Advanced Dewlayer is developed by WesternDeal allows you to show list of MP3’s on your site or blog by fetching them from single directory on your server. You have to use shortcode into your page/post with path of your MP3 folder from which you want to fetch all MP3 files and you will see a perfect playable list of MP3’s with much more options.

Features

  • Get all MP3 files from sindle directory to display list of playable MP3s with other information and download option
  • You can also include single mp3 file from local or remote server
  • Plugin settings allows you to manage playing list of MP3s

MP3 files from single directory

You can use below shortcode for fetching all MP3’s from single directory on your site:

[musicdirectory path=”path of directory from which you want to fetch MP3’s”]

Examples

1. [musicdirectory path="myaudio/"]

2. [musicdirectory path="wp-content/myaudio/"]

Remember: Don’t forget to Include trailing slash (/) at the end of path and use relative path (relative to your site’s root).

For Documentation in PDF Please Click Here

Advanced Dewplayer PRO VERSION is AVAILABLE now. Download Here

Screenshots

  • Plugin Settings
  • Front-end look

FAQ

What to do if encounter warning: filesize() stat failed ?

Please make sure that directory path you enter for MP3 files fetching has trailing slash (i.e. ‘/’) at the end.

How to use this plugin shortcode in template files ?

use following code for inserting shortcode into template file:

<?php 
echo do_shortcode('[musicdirectory path="playlist/"]');   //replace playlist with your path 
?>

Reviews

Read all 6 reviews

Changelog

1.1

  • fix URL issues
  • add custom name for single MP3 file

1.2

  • fix some download bugs

1.3

  • fix CVE-2013-7240 issue

1.4

  • Removed a feature as part of CAPEC-148 Content Spoofing security vulnerability

1.5

  • Removed Content Spoofing security vulnerability issues and compatible with wordpress 4.1

Contributors & Developers

This is open source software. The following people have contributed to this plugin.

Contributors

Browse the code