WordPress.org

Ready to get started?Download WordPress

Forums

xmlrpc ????? (5 posts)

  1. metaactive
    Member
    Posted 9 years ago #

    Has anyone tested WordPress 1.2 mingus's xmlrpc.php file,I tried it with w.bloggar and Sause Reader..It doesnt work or rather return bad expression or so.There has been two posts about it I think.And also a there is a patch
    http://mycvs.org/archives/category/technology/wordpress/
    but that too seems to be not working.
    Any feed back on the mingus xmlrpc.php would be great,should I switch to the latest nightly build to over come this and post via w.bloggar and Sause Reader. etc
    Thanks
    abm

  2. metaactive
    Member
    Posted 9 years ago #

    I seem to get this error
    XML Parsing Error: xml processing instruction not at start of external entity
    Location: http://example.com/wp/xmlrpc.php
    Line Number 2, Column 2: <?xml version="1.0"?>
    -^
    The Below is a sample working (? or is it not ) out put..
    <?xml version="1.0" ?>
    - <methodResponse>
    - <fault>
    - <value>
    - <struct>
    - <member>
    <name>faultCode</name>
    - <value>
    <int>103</int>
    </value>
    </member>
    - <member>
    <name>faultString</name>
    - <value>
    <string>XML error: no element found at line 1</string>
    </value>
    </member>
    </struct>
    </value>
    </fault>
    </methodResponse>

  3. Anonymous
    Unregistered
    Posted 9 years ago #

    Did you try this Combined Patch yet?
    What are you trying to do, exactly? Create a new post, editing an existing post, adding categories? If you provide more detail, I can see if I can help you.
    I have a client that uses w.bloggar with the aforementioned patch succesfully.
    Best regards
    Johann

  4. metaactive
    Member
    Posted 9 years ago #

    First thank you for your reply,I was trying to post via w.bloggar,or Sauce Reader,but they were giving me errors.I tried the above mentioned Combined Patch.Sauce Reader gives the error "Bad response given by xmlrpc.php",I use word press mingus 1.2.IE gave the following error while I tried to run http://example.com/wp/xmlrpc.php
    End element was missing the character '>'. Error processing resource 'http://metaactive.com/wp/xmlrpc.php'. Line 16, Position 11
    </fault></methodRespon
    ----------^
    And Fire Fox
    XML Parsing Error: xml processing instruction not at start of external entity
    Location: http://metaactive.com/wp/xmlrpc.php
    Line Number 2, Column 2: <?xml version="1.0"?>
    -^
    I assume that some error exist.
    Is there a pattern in which I should replace files or just xmlrpc.php,any way to test were the error occurs ?.I did just
    as told in
    http://mycvs.org/archives/2004/08/22/
    combined-xml-rpc-patch-for-wordpress-12-and-ecto/
    I tried it but no luck.
    Basically I'm trying to post via w.bloggar/Sause Reader,but fail due to some script error in the php files,could be malformed php or xml or simply the script failing.My host is
    PHP Version 4.3.4
    Windows NT 1 5.2
    Thanks anyway
    abm
    abm

  5. metaactive
    Member
    Posted 9 years ago #

    bump

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.