WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
WP Super Cache plugin "doesn't work" (13 posts)

  1. dokk2018
    Member
    Posted 3 years ago #

    Hi. I have a problem with CPU load, it's over the line of 10% permitted on my hosting. So I tryed to swith on caching with WP Super Cache. I activeted WPSC with defaults(then experiment with some parameters) and CPU load not go down, but a little up. It looks like the working of plugin makes load of CPU.

    Setting was:
    -ON WP Cache and Super Cache enabled
    -Don’t cache pages for known users. (Logged in users and those that comment)
    -Clear all cache files when a post or page is published. (This may significantly slow down saving of posts.)
    -Only refresh current page when comments made.
    -Expire time:7200 seconds

    Then I have tryed to reinstall plugin. I've done "1" in uninstall.php. But when I clear necessary for WPSC strings from .htaccess works only the main page of my site, all other links goes to page 404, including links from search engines. So I leave this file not clearing. How to clear it?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    You probably removed the WordPress .htaccess rules too. Go to Settings->Permalinks and set them there again if you need to.

    I don't know why the plugin didn't work. Perhaps you can try the debug system in the plugin (scroll down the admin page and you'll find it) and use it to figure it out.

  3. dokk2018
    Member
    Posted 3 years ago #

    "You probably removed the WordPress .htaccess rules too." - No.
    "Go to Settings->Permalinks and set them(what?) there again if you need to." - Permalinks: /%category%/%postname%/

  4. dokk2018
    Member
    Posted 3 years ago #

    Debugging is on. Where is the file with debug info?

  5. dokk2018
    Member
    Posted 3 years ago #

    E-mail:
    -In WP Cache Phase 2
    -No wp-cache file served as user agent rejected.
    -USER AGENT (Mozilla/5.0 (compatible; YandexBot/3.0; +http://yandex.com/bots)) rejected. Not Caching
    -Supercache caching disabled. Only using wp-cache. Non empty GET request.
    -Setting up WordPress actions
    -No wp-cache file exists. Must generate a new one.
    -No closing html tag. Not caching.
    -Buffer is blank. Output buffer may have been corrupted by another plugin or this is a redirected URL. Look for text 'ob_start' in the files of your plugins directory.
    -Output buffer callback
    -Setting up WordPress actions
    -Created output buffer
    -Supercache caching disabled. Only using wp-cache. Non empty GET request.
    -supercache dir: /*/*/*/*/*/*/wp-content/cache/supercache/*/
    -In WP Cache Phase 2
    -No wp-cache file exists. Must generate a new one.
    -Setting up WordPress actions
    -Created output buffer
    -supercache dir: /*/*/*/*/*/*/wp-content/cache/supercache/*/*/*/
    -In WP Cache Phase 2
    -Renamed temp supercache file to /*/*/*/*/*/*/wp-content/cache/supercache/*/*/*/index.html
    -Writing non-gzipped buffer to supercache file.
    -supercache dir: /*/*/*/*/*/*/wp-content/cache/supercache/*/*/*/
    -supercache dir: ...
    -Output buffer callback
    -Anonymous user detected. Only creating Supercache file.
    -No closing html tag. Not caching.

    That's all for now.

  6. dokk2018
    Member
    Posted 3 years ago #

    Main page

    <!-- Dynamic page generated in 3.825 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2010-08-26 20:10:45 -->

  7. dokk2018
    Member
    Posted 3 years ago #

    Config in plugin admin(points on):
    -ON WP Cache and Super Cache enabled
    -Refresh preloaded cache files every 0 minutes. (0 to disable, minimum 30 minutes.)
    -Many emails, 2 emails per 100 posts.
    -Expire time: 3600 seconds

  8. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    These are the important lines:

    "No closing html tag. Not caching.
    -Buffer is blank. Output buffer may have been corrupted by another plugin or this is a redirected URL. Look for text 'ob_start' in the files of your plugins directory."

    The plugin isn't getting any data to cache unfortunately. As it says, look for the text "ob_start" in the files of your plugins directory.

  9. mrmist
    Forum Janitor
    Posted 3 years ago #

    [Mod Note: I've deleted a number of large pastes from this thread. If you want to post large blocks of code, please use a pastebin (Alternate URL). Thanks!]

  10. dokk2018
    Member
    Posted 3 years ago #

    So ob_start in plugins:
    -akismet
    -platinum-seo-pack
    -si-contact-form
    -simple-forum
    -subscribe-to-comments
    -wp-insert
    -wp-super-cache
    -wp-useronline
    -yet-another-related-posts-plugin

  11. dokk2018
    Member
    Posted 3 years ago #

    What should I do?

  12. dokk2018
    Member
    Posted 3 years ago #

    so?

  13. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    You'll have to figure out which plugin is misbehaving. Disable them one by one until caching works again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic