WordPress.org

Ready to get started?Download WordPress

Forums

Table 'wordpress.wp_options' doesn't exist (6 posts)

  1. bombom
    Member
    Posted 10 years ago #

    I don't really know, but don't you have to change "wordpress" to your database's name in the config-file?
    But if this is correct, I still have the same problem.
    It just says a couple of times

    SQL/DB Error --
    [Table 'DB69856.wp_options' doesn't exist]

    And to the end it goes

    SQL/DB Error --
    [Table 'DB69856.wp_users' doesn't exist]

    I must admit, I don't really have a clue. =(

  2. pezastic
    Member
    Posted 10 years ago #

    The config file has the correct information for my database name, username, password, and host. I just went ahead and continued on from the aforementioned error and now I'm getting Windows error popups in WP options, always regarding nil value in a field.

  3. TechGnome
    Moderator
    Posted 10 years ago #

    If doing a clean install, you may get a couple warnings during the install process about tables missing. This is because they have not yet been completed. If you get through the ENTIRE install process and still get these errors when viewing the page, then there might be something further that needs to be looked at.
    TG

  4. Laughinglizard
    Member
    Posted 10 years ago #

    @pezastic: Under your admin page, look under options, base settings and then look for the siteurl box. Make sure that it points to the WordPress folder where you have it installed, with no trailing slash. Then try the login again and see if the formatting shows up correctly.

  5. pezastic
    Member
    Posted 10 years ago #

    I'm sorry. Through the multiple reinstalls, I neglected to update that field this last time. Thanks for the reminder. Now, I can go play with the other kiddies!

  6. likoma
    Member
    Posted 8 years ago #

    I just had the same error, but it turned out to be the "stattraq-button-plugin.php" that was looking for a table called "wp_options".

    If, in your config.php file, you give your prefix as "wp_" you shouldn't have this problem, but I always gave the prefix as "00_" (from back in the days when I used to do multiple WP installs for one site) and that was the problem. Either change your prefix in your config file or go change line 13 of stattraq-button-plugin.php.

    $table_prefix = '00_'; // example: 'wp_' or 'b2' or 'mylogin_'

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.