WordPress.org

Ready to get started?Download WordPress

Forums

Simple Tags
Problem with SyntaxHighlighter Plugin (9 posts)

  1. manoelcampos
    Member
    Posted 3 years ago #

    I'm using this great plugin and I found a problem when I have a post showing a source code using SyntaxHighlighter plugin.

    The Simple Tags add links into the source code highlighted by SyntaxHighlighter, but this links are not rendered and the HTML code of the link are showed to the user.

    I think that the plugin doesn't add links to text involved em shortcodes (used in plugins like SystaxHighlighter), how [html][/html], [java][/java], [c][/c], and others shortcodes.

    http://wordpress.org/extend/plugins/simple-tags/

  2. but this links are not rendered and the HTML code of the link are showed to the user.

    Because this is intended. The whole point of the plugin to show the source.

    Simple Tags is at fault here.

  3. manoelcampos
    Member
    Posted 3 years ago #

    So, I think that the Simple Tags plugin wouldn't add links to text involved in shortcodes (used in plugins like SystaxHighlighter), how [html][/html], [java][/java], [c][/c], and others).

    Is there any possibility to resolve this problem?

  4. You'd need to take it up with the author of that plugin.

  5. manoelcampos
    Member
    Posted 3 years ago #

    I think that you didn't understand the problem. The Simple Tag plugin add HTML code to display a link do some tags. When this links are inserted between a shortcode like [java][/java], because the content in this tags are showed without render the HTML code inside, the HTML tags inserted by Simple Tags are not rendered.

    But in what plugin's file/function I can change this behaviour?

  6. I think that you didn't understand the problem.

    Simple Tags is making something between my shortcodes into a link and it's showing up as <a href="http://google.com">Google</a> instead of Google, am I right?

    If so, then my plugin is working exactly how it's supposed to. It's displaying the source code of anything between it's shortocdes. If you don't want that to happen, then make Simple Tags stop adding links.

  7. manoelcampos
    Member
    Posted 3 years ago #

    Yes, but this is exactly the problem. See the picture at http://tinypic.com/view.php?pic=24ys9k9&s=7

    It shows a code in Lua Language highlighted by SyntaxHighlighter plugin. See that the first line has the word "ncluasoap" that is a tag of my post.

    When I enable Simple Tag AutoLink, the code is changed to the picture shown at http://tinypic.com/view.php?pic=2lvigyf&s=7

    Note that is added a link to ncluasoap tag but this is not rendered. Thus, this damages the code in Lua Language.

    If I manually introduce a HTML link between a SyntaxHighlighter shortcode, this must be shown whitout render the HTML code. But a link introduced automatically must be rendered or not inserted, because, if inserted, it damages the original code between the shortcodes.

  8. As I've tried to explain, Simple Tag AutoLink is at fault here.

  9. manoelcampos
    Member
    Posted 3 years ago #

    Ok. I understood that the problem was with SyntaxHighlighter plugin.
    I will try to fix the problem. Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic