WordPress.org

Ready to get started?Download WordPress

Forums

Quick Preview
[resolved] No preview (18 posts)

  1. Li-An
    Member
    Posted 1 year ago #

    On a test blog -no other plugin, default theme - on two different browsers, no preview - pop up or same window.

    http://wordpress.org/extend/plugins/quick-preview/

  2. FajitaNachos
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Li-An,

    Thanks to your post, I noticed a bug that if you are in the visual editor, you have to click outside the text area and then hit ctrl-s. That's not nearly as convenient. I'm going to work on a fix for it.

    If you aren't using the visual editor please let me know what browsers/operating systems you tried and I'll see if I can track the problem down.

    Thanks for bringing it to my attention.

  3. FajitaNachos
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like WordPress allows you to use ctrl-s to save a post in the visual editor and it is conflicting with my plugin. It might take me a little bit to find a solution, but I'm on it.

  4. Li-An
    Member
    Posted 1 year ago #

    Well... I was in HTML mode :-)
    I'm on Windows 7 32 bits, Firefox and Maxthon 3 (Webkit) were used for the test.

  5. FajitaNachos
    Member
    Plugin Author

    Posted 1 year ago #

    I'm on Windows 7 and Firefox/Chrome and it works for me. That's strange. I'll do my best to figure it out in the next couple of days. Thanks for the help.

  6. Li-An
    Member
    Posted 1 year ago #

    Well, I've no explanation. I've tested on Internet Explorer too and same problem.

  7. FajitaNachos
    Member
    Plugin Author

    Posted 1 year ago #

    Can you try uninstalling/reinstalling and activating it again? I just tried it on a fresh install from the plugin menu and everything is working (Other than the visual editor bug) in Chrome, Firefox, and IE.

  8. Li-An
    Member
    Posted 1 year ago #

    Sorry, it did not the trick... I will try to make the test on another computer today.

  9. Li-An
    Member
    Posted 1 year ago #

    OK, I tested on a brand new laptop... and it did not work. Sorry...

  10. Li-An
    Member
    Posted 1 year ago #

    Well, I asked some friends to test your plugin and it does not work for them either.

  11. FajitaNachos
    Member
    Plugin Author

    Posted 1 year ago #

    Ok. I'll test it on a friend's computer. If it doesn't work I'll remove it from the directory. I haven't had any issues on my main computer though.

  12. FajitaNachos
    Member
    Plugin Author

    Posted 1 year ago #

    I just updated the plugin. Version 1.1 fixes the bug in the visual editor and hopefully resolves any problems you are having. I've tested it on Chrome 22, Firefox 15, and IE 9 all on Windows 7. I also tested it on another laptop and everything seems savvy on my end. If you are still having problems please let me know. I appreciate the effort you have put in testing the plugin.

  13. Li-An
    Member
    Posted 1 year ago #

    Epic fail :-( Sorry, it does not want to work on my computer. Very frustrating as your plugin is a very nice idea.

  14. FajitaNachos
    Member
    Plugin Author

    Posted 1 year ago #

    Yeah that's pretty frustrating. Just to double check, did you update the plugin, clear your cache, and try it?

    What happens whenever you hit ctrl-s?

    I'll look into it some more but since it's working on both of my computers it's hard for me to know where else to look.

  15. Li-An
    Member
    Posted 1 year ago #

    When clicking Ctrl+S, the post is saved and that's all. No preview -new window or actual window. I cleaned the cache to see.
    Firefox and Webkit.

  16. FajitaNachos
    Member
    Plugin Author

    Posted 1 year ago #

    I haven't had any reports in the last 5 months of the preview window not opening. I've also tested the plugin several times on other computers and haven't run into any issues. I'm going to mark this as resolved unless you feel like I shouldn't.

  17. Li-An
    Member
    Posted 1 year ago #

    Well, it does not want to work with my browsers... Too bad for me. You can put it "solved" if you want.

  18. FajitaNachos
    Member
    Plugin Author

    Posted 1 year ago #

    I marked this resolved before your comment. I'm not sure there is a way to change that now.

    However, I did have one more thought. Please go to your settings menu in WordPress and click on quick-preview. See which window option is selected. If you have it set to open in a new window, then you need to add your blog to your browsers exception list for pop ups. That may be the reason you are not getting the preview to open.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.