WordPress.org

Ready to get started?Download WordPress

Forums

Flattr
[resolved] Cannot authorize with application (63 posts)

  1. berinder
    Member
    Posted 3 years ago #

    Hello,

    I'm working thru the Advanced setup and is stuck on step 7. I have filled in my key and secret but nothing happens when i click Authorize.

    I have tried to confirm it using step 8 but i get nothing.

    If i instead try to use teh reauthorize option on the bottom i get a message saying: "An error with the sent parametrs occurred.Go back".

    Not sure if problem is located in plugin or at the flattr-api, obviously.

    Regards,
    Leif Ershag

    http://wordpress.org/extend/plugins/flattr/

  2. berinder
    Member
    Posted 3 years ago #

    Now also tried in 3.1 with exactly the same outcome.

  3. Michael Henke
    Member
    Plugin Author

    Posted 3 years ago #

    after inserting both values hit [enter] to save then. Only then you should click Authorize.

  4. berinder
    Member
    Posted 3 years ago #

    I did that. At the end of step 6 it says, Save Changes, so i clicked save changes. After that i clicked the Authorize link, when the page had reloaded, and.... nothing. Nothing at all. It is as if i didn't click.

    Frustrating...

  5. berinder
    Member
    Posted 3 years ago #

    Here's the feedback info.
    non-Apache web Server
    LIBXML_VERSION: 20703
    cURL extension installed. 7.19.3

  6. Michael Henke
    Member
    Plugin Author

    Posted 3 years ago #

    Can you copy-paste the url the link is sending you to pleasE?

  7. berinder
    Member
    Posted 3 years ago #

  8. Michael Henke
    Member
    Plugin Author

    Posted 3 years ago #

  9. berinder
    Member
    Posted 3 years ago #

    Ok, now i see what i did. That is the link in step 7, which i though was a link to actually authorize the app... Now i see it's just an anchor down to the button.

    The link down there looks like this:
    http://api.flattr.com/oauth/authorize?oauth_token=&access_scope=read,readextended,click,publish
    and if i click it i get a screen that says:
    <blockquoteAn error with the sent parametrs occurred.Go back

    Greatly appreciating the help btw!

  10. berinder
    Member
    Posted 3 years ago #

    It's lacking the oauth token i just noticed, any ideas how that could be?

  11. Michael Henke
    Member
    Plugin Author

    Posted 3 years ago #

    Maybe resetting browser cache and cookies helps?

  12. berinder
    Member
    Posted 3 years ago #

    Afraid not, still not creating the token...

  13. Michael Henke
    Member
    Plugin Author

    Posted 3 years ago #

    What is the plugin suggesting as your callback domain?

  14. berinder
    Member
    Posted 3 years ago #

    leif.ershag.se

  15. Michael Henke
    Member
    Plugin Author

    Posted 3 years ago #

    This sound all right... No clue why it is not working out for your blog...

  16. berinder
    Member
    Posted 3 years ago #

    No, that was me trying markup at half past eleven in the evening ;)

  17. Michael Henke
    Member
    Plugin Author

    Posted 3 years ago #

    so, your running wordpress 3.1 and flattr plugin 0.9.22.2 ?

  18. berinder
    Member
    Posted 3 years ago #

    Yes and Yes, First try was with 3.0.5 and tried again with 3.1 today.

    I have also tried to remove the old app and registred a new one with no success.

  19. Michael Henke
    Member
    Plugin Author

    Posted 3 years ago #

    I'm sorry, I have absolutely no idea why it's not working...

  20. berinder
    Member
    Posted 3 years ago #

    Thanks for the try, will have to settle without autosubmit and rss-buttons then.

    Thanks for the effort!

  21. Michael Henke
    Member
    Plugin Author

    Posted 3 years ago #

    Do you think there might be a problem with your webserver communicating with flattr.com? (e.g. firewall rules for outgoing traffic invoked by php curl module)

  22. berinder
    Member
    Posted 3 years ago #

    I'm planning on running some debug-sessions soon, see if i can find the problem. the curl-settings is very possibly a hinder. I'm not in control of the server and the settings so it sounds like a proable cause.

  23. Jan
    Member
    Posted 3 years ago #

    I have the same problem.
    I sniffed the traffic going to api.flattr.com and this is the result:

    Request from my blog:
    [Code moderated as per the Forum Rules. Please use the pastebin]

    Response from api.flattr.com

    [Code moderated as per the Forum Rules. Please use the pastebin]

    Callback Invalid. What could that mean?

    My blog is installed at jan.varwig.org.
    The flattr plugins callback domain is just "varwig.org"
    Could that be the problem?

  24. Jan
    Member
    Posted 3 years ago #

    Solved this.

    Had to register a new app with flattr using the correct full domain "jan.varwig.org".

  25. Michael Henke
    Member
    Plugin Author

    Posted 3 years ago #

    Good job!

  26. Numendil
    Member
    Posted 3 years ago #

    Hello,

    i'm trying to fix the same problem since this night.

    I'm having exactly the same problem than berinder :

    i'm on wordpress, 3.1.1, with the latest Flattr plugin version, but it seems there's a problem.

    I've registered my blog as an application, as the 8 step installation explain.

    With this, Flattr gives me two keys, the API_KEY and the secret key, i've put them in the plugin but it didn't work.

    i've already tried to install/uninstall the plugin, same problem.

    i've also check for the latest versions of WP & the plugin, theses are the latest, so, i'm a little bit stuck /=

    Can you help me?

    PS : My flattr feedback : non-Apache web Server
    LIBXML_VERSION: 20632
    cURL extension installed. 7.18.2

    The url : http://api.flattr.com/oauth/authorize?oauth_token=&access_scope=read,readextended,click,publish when i click on re authorize with flattr.

  27. Jan
    Member
    Posted 3 years ago #

    Did you use the correct callback domain as described n my post?

  28. Numendil
    Member
    Posted 3 years ago #

    i tried to understand your post, but i'm unable to, i mean, my website is my blog, if you go on http://pixellibre.net you will have my blog.

    The plugin asks me to put pixellibre.net in the callback domain and i don't know if I can put something else.

    If i can, what should i put on the callback?

    Thanks :)

  29. Jan
    Member
    Posted 3 years ago #

    Hm, from looking at your blog, in your case it seems everything is fine.

    When you're in the admin panel, editing options for the Flattr plugin, is the domain still "pixellibre.net"? Because that's the URL that is used for the callback.

    If the callback domain is not the problem, then I don't know, sorry.
    Fixing the domain solved the issue for me, but maybe in your case it's a different issue.

  30. Numendil
    Member
    Posted 3 years ago #

    Thanks for the answer

    So, when I'm in the admin panel (so logged on, in the editing options for the Flattr plugin), i'm still on http://pixellibre.net/wp-admin/admin.php?page=flattr/settings.php.

    So, I'm on the domain, even if I'm on the wp-admin pannel, right?

    In all case, there's one thing i don't understand : the plugin seems to work cause when i publish a new post, this post is also created on flattr. I can click on the Flattr Button, then log in into flattr and all theses thing BUT, when i'm logged into flattr, theses topics are not in my account... it like if the pixellibre's posts are (and aren't in the same time) mine.

    Jan, thanks for your help, I'm gonna wait & see if me or someone else is able to find an issue :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags