WordPress.org

Ready to get started?Download WordPress

Forums

BTEV
[resolved] Errors when activating plugin in WP 3.2.1 (5 posts)

  1. umertin
    Member
    Posted 2 years ago #

    Hi,

    when I try to activate BTEV in my WP 3.2.1 installation, I receive a page full of errors:

    2048: Only variables should be passed by reference in /www/htdocs/w00bc54b/wordpress/wp-includes/pomo/mo.php on line 184
    2048: Only variables should be passed by reference in /www/htdocs/w00bc54b/wordpress/wp-includes/pomo/mo.php on line 184
    2048: Only variables should be passed by reference in /www/htdocs/w00bc54b/wordpress/wp-includes/pomo/mo.php on line 184
    8: Undefined variable: option in /www/htdocs/w00bc54b/wordpress/wp-content/plugins/absolute-privacy/functions.php on line 693
    2048: Only variables should be passed by reference in /www/htdocs/w00bc54b/wordpress/wp-includes/pomo/mo.php on line 184
    2048: Only variables should be passed by reference in /www/htdocs/w00bc54b/wordpress/wp-includes/pomo/mo.php on line 184
    2048: Only variables should be passed by reference in /www/htdocs/w00bc54b/wordpress/wp-includes/pomo/mo.php on line 184
    2048: Declaration of Walker_Category_Checklist::start_lvl() should be compatible with that of Walker::start_lvl() in /www/htdocs/w00bc54b/wordpress/wp-admin/includes/template.php on line 52
    2048: Declaration of Walker_Category_Checklist::end_lvl() should be compatible with that of Walker::end_lvl() in /www/htdocs/w00bc54b/wordpress/wp-admin/includes/template.php on line 52
    2048: Declaration of Walker_Category_Checklist::start_el() should be compatible with that of Walker::start_el() in /www/htdocs/w00bc54b/wordpress/wp-admin/includes/template.php on line 52
    2048: Declaration of Walker_Category_Checklist::end_el() should be compatible with that of Walker::end_el() in /www/htdocs/w00bc54b/wordpress/wp-admin/includes/template.php on line 52
    2: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00bc54b/wordpress/wp-content/plugins/bluetrait-event-viewer/btev.php:1600) in /www/htdocs/w00bc54b/wordpress/wp-includes/functions.php on line 1716
    2: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00bc54b/wordpress/wp-content/plugins/bluetrait-event-viewer/btev.php:1600) in /www/htdocs/w00bc54b/wordpress/wp-includes/functions.php on line 1716
    2: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00bc54b/wordpress/wp-content/plugins/bluetrait-event-viewer/btev.php:1600) in /www/htdocs/w00bc54b/wordpress/wp-includes/functions.php on line 1716
    2: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00bc54b/wordpress/wp-content/plugins/bluetrait-event-viewer/btev.php:1600) in /www/htdocs/w00bc54b/wordpress/wp-includes/functions.php on line 1716
    2048: is_a(): Deprecated. Please use the instanceof operator in /www/htdocs/w00bc54b/wordpress/wp-includes/functions.wp-scripts.php on line 98
    2048: is_a(): Deprecated. Please use the instanceof operator in /www/htdocs/w00bc54b/wordpress/wp-includes/functions.wp-scripts.php on line 98
    2048: Non-static method collapsArch::setup() cannot be called statically in /www/htdocs/w00bc54b/wordpress/wp-includes/plugin.php on line 405
    2048: Non-static method collapsArch::setup() cannot be called statically in /www/htdocs/w00bc54b/wordpress/wp-includes/plugin.php on line 405
    2048: Non-static method collapsArch::setup() cannot be called statically in /www/htdocs/w00bc54b/wordpress/wp-includes/plugin.php on line 405
    2048: Only variables should be passed by reference in /www/htdocs/w00bc54b/wordpress/wp-includes/pomo/mo.php on line 184
    2048: Only variables should be passed by reference in /www/htdocs/w00bc54b/wordpress/wp-admin/includes/menu.php on line 218
    2: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00bc54b/wordpress/wp-content/plugins/bluetrait-event-viewer/btev.php:1600) in /www/htdocs/w00bc54b/wordpress/wp-includes/functions.php on line 4549
    2048: is_a(): Deprecated. Please use the instanceof operator in /www/htdocs/w00bc54b/wordpress/wp-includes/functions.wp-styles.php on line 98
    2048: Declaration of WP_Plugins_List_Table::bulk_actions() should be compatible with that of WP_List_Table::bulk_actions() in /www/htdocs/w00bc54b/wordpress/wp-admin/includes/class-wp-plugins-list-table.php on line 456
    2048: Declaration of WP_Plugins_List_Table::single_row() should be compatible with that of WP_List_Table::single_row() in /www/htdocs/w00bc54b/wordpress/wp-admin/includes/class-wp-plugins-list-table.php on line 456
    2048: is_a(): Deprecated. Please use the instanceof operator in /www/htdocs/w00bc54b/wordpress/wp-includes/functions.wp-scripts.php on line 98
    2048: is_a(): Deprecated. Please use the instanceof operator in /www/htdocs/w00bc54b/wordpress/wp-includes/functions.wp-scripts.php on line 98
    2048: is_a(): Deprecated. Please use the instanceof operator in /www/htdocs/w00bc54b/wordpress/wp-includes/functions.wp-styles.php on line 98
    2: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00bc54b/wordpress/wp-content/plugins/bluetrait-event-viewer/btev.php:1600) in /www/htdocs/w00bc54b/wordpress/wp-admin/admin-header.php on line 9

    I already disabled several plugins (Total Cache, NGG, Revision Control), because they originally were listed in error messages, but this only causes new errors. Those above were left.

    Any idea?

    Regards Ulrich

    http://wordpress.org/extend/plugins/bluetrait-event-viewer/

  2. Michael
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Ulrich,

    I am the developer of Bluetrait Event Viewer. Thankyou for trying my plugin.

    That error is odd. Did you enable the Advanced Debug options in bluetrait event viewer? This generates those messages but it is disabled by default.

    I haven't tested BTEV in WordPress 3.2 yet, so there might be a bug or a conflicting plugin (haven't found any yet).

    If you're still having issues I recommend that you disable BTEV or even all of your plugins and enable one by one.

    Thanks,
    Michael.

  3. umertin
    Member
    Posted 2 years ago #

    Hi Michael,

    thanks for your answer.

    I did not enable anything in BTEV, as I was not able to activate it without making WordPress completely unusable (I got the error messages above for all pages after enabling BTEV).
    Strangely, when I set up a second WordPress instance and installed all plugins I have in my main instance, I did not get any errors. So I will investigate further.

    Regards

    Ulrich

  4. Michael
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Ulrich,

    It kind of sounds like BTEV got corrupt on install. Did you upload the plugin or install it directly from within WordPress?

    If you're still having issues on that WordPress install I can probably write you an uninstall plugin or script.

    I've just tested BTEV on WordPress 3.2.1 and I haven't had any issues yet, so I suspect something just broke on install.

    Thanks,
    Michael.

  5. umertin
    Member
    Posted 2 years ago #

    Hi Michael,

    Disabling all plugins did not help.
    I also made sure the BTEV files were installed ok by copying the complete folder from the working instance over to the failing one, but without any success. So only the BTEV database entries could have caused the problem, or something in the main WordPress installation.

    But, as it seems that this problem is limited to me, and I did not want to spend more time on debugging, I copied over the text and media from the failing to the working instance and made the second one my main instance.
    So now I have a working WordPress installation with BTEV and can start analyzing my issues with WPG2, which started the whole thing.

    Thanks for your support (and for the great plugin, of course)

    Regards

    Ulrich

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic