WordPress.org

Ready to get started?Download WordPress

Forums

links-update-cache.xml Problems (8 posts)

  1. What is this file supposed to be set to? I keep getting this error if it's CHMOD 755. When it's set to 666, I don't get anything. And is 777 bad?
    Here's the error:

    Warning: fopen(/absolute_path/wp-content/links-update-cache.xml): failed to open stream: Permission denied in /absolute_path/wp-includes/links-update-xml.php on line 79
    Warning: fwrite(): supplied argument is not a valid stream resource in /absolute_path/wp-includes/links-update-xml.php on line 80
    Warning: fclose(): supplied argument is not a valid stream resource in /absolute_path/wp-includes/links-update-xml.php on line 81

    Thanks...

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Just checked mine - it's 777.
    I've had no problems, but then I don't altogether understand permissions and security. Anyone want to explain ? :)

  3. I don't know - just asking if there was! :D
    In your "Need more help?" WP page, you state that you'll set file permissions to 755 for that file. Should it be 777?

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    To be honest I don't know ..... I've not had any reported problems, and I've never had any with this that I can recall - could be wrong on that though.

  5. Okay...I'll leave it at 777, especially since you're not having any issues. Thanks again. :)

  6. sdollen
    Member
    Posted 9 years ago #

    Curious - why do some links not show the "updated" when you hover your mouse over the link?

  7. sdollen
    Member
    Posted 9 years ago #

    Anyone else experienced this before? Does the update-cache only work on WP blogs? That was my first thought, except that I have a couple of WP blogs in my links that don't update.

  8. Beel
    Member
    Posted 9 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.