WordPress.org

Ready to get started?Download WordPress

Forums

Functions.php Error When Publishing (8 posts)

  1. dworsky
    Member
    Posted 8 years ago #

    I installed 2.0.2 a couple of days after installing 2.0.1, according to the directions.

    Now when I write any post and publish, I get the following error (but the post is actually published despite the error):

    Warning: weblog_ping(): Unable to access /home/me/domains/mouseprint.org/public_html/wp-includes/class-IXR.php in /home/me/domains/mouseprint.org/public_html/wp-includes/functions.php on line 851

    Warning: weblog_ping(/home/me/domains/mouseprint.org/public_html/wp-includes/class-IXR.php): failed to open stream: No such file or directory in /home/me/domains/mouseprint.org/public_html/wp-includes/functions.php on line 851

    Warning: weblog_ping(): Failed opening '/home/me/domains/mouseprint.org/public_html/wp-includes/class-IXR.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/me/domains/mouseprint.org/public_html/wp-includes/functions.php on line 851

    Fatal error: Cannot instantiate non-existent class: ixr_client in /home/me/domains/mouseprint.org/public_html/wp-includes/functions.php on line 854

    ============

    Any ideas what to do to get rid of this?

    Thanks,

    Edgar

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Was it all good after the upgrade and it has just happened?
    Or is this the first post since the upgrade?

    Could be a plugin?
    Could be an incorrectly uploaded file?

  3. dworsky
    Member
    Posted 8 years ago #

    Podz...

    First post made after upgrading had this problem, and I haven't installed any plugins.

    I even re-uploaded functions.php in case something was wrong with the original... and that didn't help.

    Edgar

  4. etherwatt
    Member
    Posted 8 years ago #

    I installed WordPress 2.0.2 yesterday and I get those exact error messages as well. But i'm not even upgrading. It's a fresh install. Let's compare notes dworsky.

    this is what I get:
    Warning: weblog_ping(): Unable to access /home/virtual/site265/fst/var/www/html/bmoviematrix.com/wp-includes/class-IXR.php in /home/virtual/site265/fst/var/www/html/bmoviematrix.com/wp-includes/functions.php on line 851

    Warning: weblog_ping(/home/virtual/site265/fst/var/www/html/bmoviematrix.com/wp-includes/class-IXR.php): failed to open stream: No such file or directory in /home/virtual/site265/fst/var/www/html/bmoviematrix.com/wp-includes/functions.php on line 851

    Warning: weblog_ping(): Failed opening '/home/virtual/site265/fst/var/www/html/bmoviematrix.com/wp-includes/class-IXR.php' for inclusion (include_path='.:/php/includes:/usr/share/php:/usr/share/pear') in /home/virtual/site265/fst/var/www/html/bmoviematrix.com/wp-includes/functions.php on line 851

    Fatal error: Cannot instantiate non-existent class: ixr_client in /home/virtual/site265/fst/var/www/html/bmoviematrix.com/wp-includes/functions.php on line 854

  5. darthwalk
    Member
    Posted 8 years ago #

    same problem for me...

  6. Chris_K
    Member
    Posted 8 years ago #

    Reupload it one more time, but make sure you're in ASCII mode, not binary?

  7. darthwalk
    Member
    Posted 8 years ago #

    for me THIS problem is solved, the "class-IXR.php" was "class-ixr.php" on my server - it was case sensitive...

    now i see, that sg is broken with the extended live archive. im using K2, maybe there is sg conflict between them

  8. bluesdance
    Member
    Posted 8 years ago #

    i had the same problem.
    ah hah!!
    the case sensitive thing!!
    how stupid.
    i fixed it and now all is well!

Topic Closed

This topic has been closed to new replies.

About this Topic