WordPress.org

Ready to get started?Download WordPress

Forums

error in wp-db.php and pluggable.php (14 posts)

  1. weenskee
    Member
    Posted 6 years ago #

    Hi...

    I just uploaded the version 2.3.2 to my host and this message was shown:

    Warning: error_log() has been disabled for security reasons in /www/freeweb7.com/w/e/e/weenskee/htdocs/wp-includes/wp-db.php on line 163

    Warning: Cannot modify header information - headers already sent by (output started at /www/freeweb7.com/w/e/e/weenskee/htdocs/wp-includes/wp-db.php:163) in /www/freeweb7.com/w/e/e/weenskee/htdocs/wp-includes/pluggable.php on line 391

    what do I do to solve this??

    Thanks...

  2. Huda
    Member
    Posted 6 years ago #

    Maybe it's because error_log() function is disabled by your server administrator. Not all server faces this problem.

    And I think it's a bug in 2.3.2. WordPress should check whether the function is enabled by the server or not before calling it. Try commenting the error_log() call on wp-db.php line 163 until future fixes.

    e.g.:
    /* error_log($error_str, 0); */

  3. aidanacker
    Member
    Posted 6 years ago #

    Thanks for the advice. Commenting the error log out worked for me. I think some web hosts don't enable the function as you said.

  4. MichaelH
    Member
    Posted 6 years ago #

    re: host http://www.zymic.com

    Confirming this change (commenting out line 163 in /wp-includes/wp-db.php at 2.3.2) fixed the problem when using host http://www.zymic.com and allowed installation of WordPress to complete successfully.

  5. MichaelH
    Member
    Posted 6 years ago #

    re: http://www.110mb.com

    Confirming this change (commenting out line 163 in /wp-includes/wp-db.php at 2.3.2) fixed the problem when using host http://www.110mb.com and allowed installation of WordPress to complete successfully.

  6. rankspace
    Member
    Posted 6 years ago #

    This change had no effect for me regarding this error. I did find extra lines beneath the final ?> in my functions.php. Removal of these corrected the problem.

  7. MichaelH
    Member
    Posted 6 years ago #

    @rankspace - which functions.php file did you edit? There's more than one.

  8. DigTheDupe
    Member
    Posted 6 years ago #

    The same problem on 1 hosting on half of my WordPress 2.3.2 blogs:

    Warning: Cannot modify header information - headers already sent by (output started at /home/ga/public_html/wp-settings.php:266) in /home/ga/public_html/wp-includes/pluggable.php on line 341

    Warning: Cannot modify header information - headers already sent by (output started at /home/gasyoun/public_html/esiod.com/wp-content/themes/illacrimo/functions.php:24) in /home/ga/public_html/ga/wp-includes/pluggable.php on line 391

  9. whooami
    Member
    Posted 6 years ago #

  10. MichaelH
    Member
    Posted 6 years ago #

    The resolution (comment out line 163 in wp-includes/wp-db.php at 2.3.2) worked on a http://www.plus.net hosted account. Interestingly, just an internal server error message was displayed before the fix was applied.

  11. MichaelH
    Member
    Posted 6 years ago #

    The fix (comment out line 163 in wp-includes/wp-db.php at 2.3.3) worked on a http://www.daily.co.uk hosted account. Interestingly, attempting the wp-admin/install.php, the site just kept trying and trying, then after 2 or 3 minutes, an "Internal Server Error" message was displayed. Applying the fix allowed the installation to happen.

  12. jphill77
    Member
    Posted 6 years ago #

    None of the fixes above seemed to work for me, even after upgrading to the latest version of WordPress. The actual blog works fine, but then when I try to login I get this error...

    Warning: Cannot modify header information - headers already sent by (output started at /home/trideade/public_html/blog/wp-config.php:25) in /home/trideade/public_html/blog/wp-login.php on line 12

    Warning: Cannot modify header information - headers already sent by (output started at /home/trideade/public_html/blog/wp-config.php:25) in /home/trideade/public_html/blog/wp-login.php on line 24

    Can someone help me out please?

  13. whooami
    Member
    Posted 6 years ago #

    remove the line breaks OR spaces that are after the closing ?> inside your wp-config.php

  14. jonbolden
    Member
    Posted 6 years ago #

    remove the line breaks OR spaces that are after the closing ?> inside your wp-config.php

    That worked! I was getting "Headers already sent" on wp-config was well and all I did was delete the extra spacing, lines after the ?> on wp-config.php. Thanks whooami

Topic Closed

This topic has been closed to new replies.

About this Topic