WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Another uploading problem (11 posts)

  1. Anne-Marie
    Member
    Posted 8 years ago #

    Or I'm being blond again or I'm the first with this problem but I did search and search and search and I couldn't find any thing that would have helped me prove that it has nothing to do with my hair color (yet).

    I've tried uploading an image, I've set all the chmods correctly, it uploads the image fine but then I get the next warning:

    imagejpeg(): Invalid filename '/home/****/domains/www.com/public_html/***/wordpress/wp-content/bb_background.thumbnail.jpg' in /home/****/domains/www.com/public_html/***/wordpress/wp-admin/admin-functions.php on line 761
    Thumbnail path invalid.

    I've tried using WP-upload and the Filosofo Old-Style Upload plugin, both gave me the same warning.
    Where did I go wrong...do I need to create a thumbnail file? Or something else...any help would be obliged.

    TIA

  2. Anne-Marie
    Member
    Posted 8 years ago #

    Probably I should have gave this little problem another title, "another upload problem" is just one of the many :(

    But anyways anybody have a clue what I should do to make my problem go away?

  3. red-star
    Member
    Posted 8 years ago #

    Why do you upload your image in the wp-content folder? Why not in the image folder? Just a question to understand the motivation.

  4. Anne-Marie
    Member
    Posted 8 years ago #

    'Cause there is where WP wants me to upload my images, I've changed this several times under options -> uploads, but when doing so WP gives me the: Unable to create directory /home/***/domains/***/public_html/***/wordpress/wp-content/uploads/2006/03. Is its parent directory writable by the server, warning.

    Just to be sure...I did chmod this path aswell, then I get the first mentioned problem.

  5. moshu
    Member
    Posted 8 years ago #

    Is its parent directory writable by the server

    The "parent" is wp-content. That's the one that should be writable.

  6. Anne-Marie
    Member
    Posted 8 years ago #

    Yup...everything is set to 777.

  7. Kafkaesqui

    Posted 8 years ago #

    Could be this bug (does your host run PHP in safe mode?):

    http://trac.wordpress.org/ticket/2402

  8. Anne-Marie
    Member
    Posted 8 years ago #

    Kafkaesqui, that link is exactly what I keep encountering. And yes my host runs PHP safe mode.

    So if I understand correctly it has to do with the PHP safe-mode?

  9. Kafkaesqui

    Posted 8 years ago #

    Yep. I won't blame safe mode for all of society's ills, but there's a number of (real good) reasons why it's being phased out of PHP.

    You could try changing the code in admin-functions.php as mentioned in the "patch," which is the addition of this line after $thumbpath is assigned:

    touch($thumbpath);

  10. Anne-Marie
    Member
    Posted 8 years ago #

    Thnx..am at work now but shall give it a try a soon I get back home. Will up-date if it worked or not.

  11. Anne-Marie
    Member
    Posted 8 years ago #

    Don't know what happened here but I tried adding: touch ($thumbpath); in the admin-functions.php and after that there was no possibility I could ever login again. Luck that it was just my testing blog, and I could undo by a clean install (saves the hassle of up-dating to 2.0.1) but somehow it looks like I'm not aloud to upload files :(

    Guess I can live with that.

Topic Closed

This topic has been closed to new replies.

About this Topic