WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Quick Contact Form

Simple plug and play contact form.

Requires: 3.0 or higher
Compatible up to: 3.8.3
Last Updated: 2014-6-24
Downloads: 43,970

Ratings

4 stars
4.2 out of 5 stars

Support

0 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,3,3
0,1,0 0,1,0
100,1,1
100,1,1
100,1,1