{"id":3584228,"date":"2013-03-21T17:03:32","date_gmt":"2013-03-21T17:03:32","guid":{"rendered":"https:\/\/wordpress.org\/support\/topic\/error-in-sql-statements\/"},"modified":"2016-08-20T23:01:06","modified_gmt":"2016-08-20T23:01:06","slug":"error-in-sql-statements","status":"closed","type":"topic","link":"https:\/\/wordpress.org\/support\/topic\/error-in-sql-statements\/","title":{"rendered":"Error in SQL Statements"},"content":{"rendered":"<p>Hi,<\/p>\n<p>This is more FYI than a request for support, as I&#8217;ve resolved my own issue.<\/p>\n<p>In the latest release of ndizi 0.9.7.0, the SQL statements to create the necessary tables have error that cause the tables to not be installed (at least with MySQL version 5.1.57).<\/p>\n<p>This issue will cause you to not be able to enter any clients, projects, etc after activating the plugin.<\/p>\n<p>The problem is that the &#8216;description&#8217; fields in each table are being create as a TEXT type with a DEFAULT value. <\/p>\n<p>According to MySQL, that is a no-no.<\/p>\n<p>You can fix this problem by opening Ndizi.class.php in notepad and deleting &#8220;DEFAULT &#8221;&#8221; from each statement that&#8217;s creating a table.<\/p>\n<p>https:\/\/wordpress.org\/extend\/plugins\/ndizi-project-management\/<\/p>\n","protected":false},"template":"","class_list":["post-3584228","topic","type-topic","status-closed","hentry"],"jetpack_sharing_enabled":true,"_links":{"self":[{"href":"https:\/\/wordpress.org\/support\/wp-json\/wp\/v2\/topic\/3584228","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/wordpress.org\/support\/wp-json\/wp\/v2\/topic"}],"about":[{"href":"https:\/\/wordpress.org\/support\/wp-json\/wp\/v2\/types\/topic"}],"version-history":[{"count":0,"href":"https:\/\/wordpress.org\/support\/wp-json\/wp\/v2\/topic\/3584228\/revisions"}],"wp:attachment":[{"href":"https:\/\/wordpress.org\/support\/wp-json\/wp\/v2\/media?parent=3584228"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}