{"id":3491855,"date":"2013-02-21T14:59:39","date_gmt":"2013-02-21T14:59:39","guid":{"rendered":"https:\/\/wordpress.org\/support\/topic\/require_once-error\/"},"modified":"2016-08-20T21:52:29","modified_gmt":"2016-08-20T21:52:29","slug":"require_once-error","status":"closed","type":"topic","link":"https:\/\/wordpress.org\/support\/topic\/require_once-error\/","title":{"rendered":"require_once error"},"content":{"rendered":"<p>I&#8217;ve just solved a maddening error, so if you get the following error:<\/p>\n<p><code>require_once(Net\/SFTP.php)<\/code><\/p>\n<p>Then the likelihood is that your apache settings are preventing the PHP function set_include_path from working (http:\/\/www.php.net\/manual\/en\/function.set-include-path.php#92504). I&#8217;m using Plesk and had the include_path PHP setting set. This prevents set_include_path from working, which knackers this plugin and quite a few other bits of software.<\/p>\n<p>By unsetting the include_path apache config value this plugin worked again.<\/p>\n<p>https:\/\/wordpress.org\/extend\/plugins\/ssh-sftp-updater-support\/<\/p>\n","protected":false},"template":"","class_list":["post-3491855","topic","type-topic","status-closed","hentry","topic-tag-apache","topic-tag-config","topic-tag-require_once"],"jetpack_sharing_enabled":true,"_links":{"self":[{"href":"https:\/\/wordpress.org\/support\/wp-json\/wp\/v2\/topic\/3491855","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/wordpress.org\/support\/wp-json\/wp\/v2\/topic"}],"about":[{"href":"https:\/\/wordpress.org\/support\/wp-json\/wp\/v2\/types\/topic"}],"version-history":[{"count":0,"href":"https:\/\/wordpress.org\/support\/wp-json\/wp\/v2\/topic\/3491855\/revisions"}],"wp:attachment":[{"href":"https:\/\/wordpress.org\/support\/wp-json\/wp\/v2\/media?parent=3491855"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}