WordPress.org

Plugin Reviews

WP Frontpage News

WP Latest post display latest posts from a category, page or tags in various way and easily. News plugin can be called in editor or as widget.

9 reviews
Average Rating
4.3 out of 5 stars
You are currently viewing the reviews that provided a rating of 5 stars. Click here to see all reviews.
Outstanding plugin
By , for WP 4.1

Most of the times people don't even know what they are doing when they first use wp and they expect that all the plugins to work out of the box and they hurry to rate 1 start for a free plugin if something it doesn't look good in their "expert" opinion and even get angry with the developer. Do not rate or use free plugins if you don't have any clue at all of what you are doing, I'm fed up with people taking the developers work for granted. This is an outstanding plugin, 5 stars all the way!

Good support
By , for WP 4.0

Plugin didn't work at first, after a quick note a developer went in and fixed the issue within a day. Good service.

Just What We Needed!
By , for WP 4.0

Thanks for this plugin - it was easy to install and works great! I upgraded to the pro version for the additional options (like more text options), and am happy with the result. Thank you!

Install Error using WP 3.9.2
By , for WP 3.9.2

Installed just like every other plugin I ever installed using the WP Admin and received this error:
Plugin could not be activated because it triggered a fatal error.

Parse error: syntax error, unexpected T_FUNCTION in /home/seopro/public_html/wp-content/plugins/wp-frontpage-news/inc/wp-fpn-main.inc.php on line 141

Excellent Frontpage Addition!
By , for WP 3.9.1

I found this plugin by accident, but I'm very glad I did! It provided needed content to my front page! And, yes PHP 5.3 is needed to make it work.

Thanks ydubois

Don't punish
By Plugin Author, for WP 3.9

I noticed some people gave 1 star or 2 stars to this plugin, just because they tried it on an unsupported version of PHP. This is unfair.

The plugin doc clearly states that PHP versions before 5.3 are unsupported. Common guys, PHP 5.2 has been deprecated and unsupported since January 2011. Let's move on... If your hosting provider does not support a newer version of PHP, change provider.

Don't give 1 star without giving hints to the developer on what you felt was wrong with the plugin.

And don't give bad ratings without even asking why it does not work for you: if you get a fatal error, chances are something is wrong on your side. Don't blame the developer for it!

When in doubt, ask before punishing.

Mixed feelings: Great and not so great
By , for WP 3.9.1

I have been using this plugin for months and it really works well. I'm using the free version.

Better than what I expected
By , for WP 3.8.2

This is really a great plugin , I searched alot for such a plugin and it gives even more than what i needed

Aweasom idea saving efforts and time
By , for WP 3.6.1

I'll put 5 stars to the author to encourage him for developing this plugin, and i hope more options and stability to make this plugin one of the favourit plugins in a short time
thanx

You must log in to submit a review. You can also log in or register using the form near the top of this page.