WordPress.org

Plugin Reviews

Toolset Types

The complete and reliable plugin for managing custom post types, custom taxonomies and custom fields.

10 reviews
Average Rating
4.3 out of 5 stars
You are currently viewing the reviews that provided a rating of 3 stars. Click here to see all reviews.
No menu "Views"
By , for WP 4.5.3

hi please help, i install this toolset but i dont have the "views" menu on my menu bar.

Doesn't automatically output custom field values without format like wp does
By ,

No overall setting to chose output. Requires designing a display on each post with shortcodes. Have to choose the date format each time the date field is used to then insert the shortcode on each post. Not even an option to include the label by default when shortcodes display values. No templates creation except with paid addon.

If I have to manually create labels within the posts, there's no point of meta boxes and custom field labels. Might as well use a page builder.

Will either go back to Pods or have to use on of these with it.
(Doesn't auto insert like a template but)
https://wordpress.org/plugins/simple-post-template/screenshots/ https://wordpress.org/plugins/easy-content-templates/screenshots/
https://wordpress.org/plugins/content-template/
https://wordpress.org/plugins/global-content-blocks/
https://wordpress.org/plugins/reusable-text-blocks/screenshots/ https://wordpress.org/plugins/infuse/
https://wordpress.org/plugins/post-snippets/screenshots/
https://wordpress.org/plugins/wp-html-block/
https://wordpress.org/plugins/wp-snippets/
https://wordpress.org/plugins/isw-blocks/screenshots/
https://wordpress.org/plugins/reusable-contents/

Bug for me
By , for WP 4.3

The plugin stops working overnight and you can not update the plugin without paying!

EDIT : Ok updated as possible by turning off - update - reactivating the plugin

=> but my bug is still present, the images 'types' no longer appear
please help

=> code that no longer works for me :
[userinfo nospan="true" field="user_login"][/userinfo]
[types usermeta="form-album-prive-image" user_current="true" output="raw"]
thanks

I problem in child product
By ,

Overall the plugin is really useful. But I got one problem.
I had add 'Children' in a parent. Both the parent and child have featured image. I am not able to set the featured image of the parent.

Please check on.

Buyer Beware! Buggy and confusing.
By ,

This plugin sounds great, but once you actually dive in to try to do something, you quickly realize that the plugin is buggy and documentation is painfully bad.

Twice I had to give the plugin support team access to our server to figure out why things didn't work correctly. The second time, the answer was just that it's a bug and the developers are working on it. I ended up reverting to an earlier version of the plugin (which I had backed up, thankfully,) which was less buggy than the newer one.

I used this because I had a very specific task (parent/child relationships between custom post types) and in the end it basically worked, although the process was not easy. It left me wondering if it would've been more efficient to just code it manually in PHP.

If you just want to set up basic custom post types, I suggest doing it manually in functions.php. Then the Advanced Custom Fields plugin is excellent for custom fields.

Nice but slow !
By , for WP 4.1

Nice plugin, nice feature which make it easy to add new categories and taxonomy, custom field and all ... but it just make the admin crawl ! Far too slow :( Too bad

Great plugin but bug was found
By , for WP 4.0

I've created custom post types. Once I edited the settings, I've got an error. Please fix.

You cannot use this slug because there is already a page by that name. Please choose a different slug.

Good but problem with the new version
By , for WP 3.6.1

I love this plugin, but the child post doesn't work in the new version, i had to take the old version (1.3).

Website slowed down.
By , for WP 3.5.1

I have 14 custom post types.
And after using P3 profiler i have found that Types plugin takes 11 seconds to display a page.
I know i can use a cache plugin to fix this issue, but is this normal? 11 seconds? It takes 2-3 seconds without the types plugin.
Please let me know.

A reasonably average plugin, with poor support
By , for WP 3.4.2

Some things I found didn't work as expected, such as password protection on pages/posts and pagination. Documentation for php integration is very light and not very well explained (e.g use of id tags beginning with $ to pull content from a specific post type - only found this through a lot of searching within the forums).

Despite being a paying customer - support for me, for some reason, is non existent. I've tried various times to post on their website forum as well as contact support regarding various issues but have received no response to any of my queries.

You must log in to submit a review. You can also log in or register using the form near the top of this page.