Plugin Reviews


Official Twitter, Vine, and Periscope plugin for WordPress. Embed content and grow your audience. Requires PHP 5.4 or greater.

Average Rating
3.4 out of 5 stars
By , for WP 4.3

had some issues at the end but its ok now

I love this plugin
By ,

I love this plugin it help in my social network.

By , for WP 4.2.2

This plugin is not useful for developers because customization is very limited. This plugin is likely to be a time drain for most developers who try it out. It's possible the plugin could be useful for some site owners who aren't picky about fonts, etc.

PHP 5.4 is restrictive
By ,

This is not much use when developing WordPress sites for customers with their own hosting as they rarely have the latest PHP version or the ability to update it. The code may be beautiful, but not supporting PHP versions commonly available in shared hosting environments is a cop out.

Good plugin
By , for WP 4.1.1

It's very good choice! thanks to this plugin, I'm still in touch with my followers and readers on my blog! I would like to really thanks for developers! Thanks guys, you'll do good work!

yeni veriyon
By , for WP 4.1.1

yeni versiyon ├žok iyi.

Twitter follow button widget not working
By ,

I have added the twitter follow button 5 times to the footer widget of my theme, both using the widgets view and appearance view, and this is the only widget that doesn't "stick" when saved. When returning to manage widgets, this one always drops off. The follow button is the main reason why I wanted this.

I'm deactivating it.

5 stars - just for the code.
By , for WP 4.1.1

If more plugins were coded like this, I would be a very happy man.

The code is solid, is mostly covered by unit tests and not built with ancient PHP versions in mind.

Wonderful! We need more plugins like this.

Requires 5.4
By , for WP 4.1.1

This plugin requires PHP 5.4.

I like it
By , for WP 4.1.1

Does pretty much what it says on the tin, however, note that you do need a host running a more recent version of PHP to use it. If you don't have PHP 5.4 or higher, the plugin will do nothing.

It doesn't actually provide a mechanism to auto-tweet your posts for you. For that, I recommend the Jetpack functionality, which works quite well. This is an understandable missing-component from the plugin, for various technical reasons.

But for all the most recent "widget" type of functionality from Twitter, this pretty much covers the gamut. It also has some of the new advertising and tracking functionality of Twitter, if you're into that sort of thing.

Good plugin, good code, solid backend.

You must log in to submit a review. You can also log in or register using the form near the top of this page.