Plugin Reviews

Social Gallery Lite

Social Gallery is the Ultimate Social Lightbox Plugin for WordPress. This is the Lite Version.

27 reviews
Average Rating
3.4 out of 5 stars
Little social sharing
By , for WP 4.3.1

The only thing you can actually share in the lite version is through facebook. so this isn't really a social gallery. It's a facebook gallery. Very misleading, IMO.

The worst.
By , for WP 4.2.2

Have to agree with DragonFlyFla with this being theorist company ever.

Speaking for other work that I purchased, it is riddled with lasting unfixed bugs, I'll worked out patches, and deceiving marketing and support that over promises and never performs. Stay away from buying any of this if I were you.

By , for WP 4.2.2


WP galleries distorted
By ,

Bought plug in and it distorted all WP galleries. Images are all over the posts, absolute mess. Had to deactive ..and all galleries fell back to normal view.

needs to learn customer service
By , for WP 4.1.1

gives intentionally misleading offers and then is rude wen confronted about it. next time you should thank a person that informs you of that you are doing something that will upset customers and cost you sales. you welcome. As for functionality i could not say. to annoyed and deleted it right away.

By , for WP 4.0

I am dissatisfaction about support.

The lost manual...
By , for WP 3.9.1

For some reason the most essential instruction is the hardest to find in the install guides and help forum. For any image you wish to use as the lightbox, you must change the Link CSS Class to socialGallery. Then it works like a charm. You can find an input box in your Image Detail popup to enter socialGallery, or you can change the code as follows (simplified to just the essential required code):

<a class="socialGallery" href="Full Size Image URL"><img src="Thumbnail or Custom Size Image URL"></a>
problem activate
By , for WP 3.4.1

Warning: file_get_contents(http://www.socialgalleryplugin.com/updateEngine/lite/?ori=http://localhost/wordpress34): failed to open stream: HTTP request failed! HTTP/1.1 500 Internal Server Error in C:\wamp\www\wordpress34\wp-content\plugins\social-gallery-lite\SocialGalleryLite.php on line 1276

not responsive unless you pay
By , for WP 3.8.1

Got this and then the pro version.
It's buggy in an ipad environment, and does not resolve correctly within the ipad screen.
to get it to work you have to pay more.
not happy. useless support.
does not do what it says on the tin, unless you are prepared to pay for more add ons.

By , for WP 3.7.1

Just Fantastic! :))

You must log in to submit a review. You can also log in or register using the form near the top of this page.