WordPress.org

Ready to get started?Download WordPress

Plugin Reviews

Polldaddy Polls & Ratings

Create and manage Polldaddy polls and ratings from within WordPress.

12

19 reviews
Average Rating
2.5 out of 5 stars
Horrible to use and buggy
By , for WP 3.5.1

Just horrible to use. Nothing seems to work properly. Maybe I'm not doing it right but I have no way to tell because there's nothing in the way of instructions in the interface. You have to just guess at what things do or are supposed to do. Embedding videos or pictures with poll answers doesn't seem to work. There doesn't seem to be any way to customise styles despite this being listed as a feature. And you need to customise the styles because the ones provided are awful and archaic-looking - I remember seeing nicer-looking geocities sites.

I can only assume the free wordpress version is deliberately borked to try and get you to pay for a pro account. Well, it hasn't worked in this case. I'll be steering well clear of polldaddy.

Generates PHP warnings and notices
By ,

Doesn't play nice with WP_DEBUG.

Just awful
By , for WP 3.5.1

I got this because it's the one used on wordpress.com. I've only used it for the ratings. Beware: you don't own any of the data collected by this plugin, polldaddy does.

In addition to that, there's limited configuration over the look and feel, I had to use a bunch of very silly css rules and workarounds to just turn certain things off to look better. You can't access the rating data via a theme, so forget about having microformats.

Good if you want to pay $200+ per year.

Crashed my site
By , for WP 3.5.1

Crashed it as soon as I activated it.

How to use Polldaddy
By , for WP 3.5.1

I just learned how to use polldaddy through trial and error. So to save you time, I chose to list the steps to getting it work for you.

Setup instructions:

1. Install and activate plugin
2. Go to http://www.polldaddy.com and register for an account.
3. Create new poll
4. Copy polldaddy shortcode into post or page. For example [polldaddy poll="69044xx"]

Bomber!
By , for WP 3.5.1

Though very hopeful, this plugin is a dud. It does not work at all with WordPress Multisite 3.5.1

Arabic
By , for WP 3.5.1

it doesn't work well in arabic

hello
By , for WP 3.5

hello

i am mausom and i create polls and i use this polls on my web site but i not use this polls my web site

No Widget
By ,

Kind of defeats the purpose

You must log in to submit a review. You can also log in or register using the form near the top of this page.