WordPress.org

Plugin Reviews

Image Watermark

Image Watermark allows you to automatically watermark images uploaded to the WordPress Media Library and bulk watermark previously uploaded images.

6 reviews
Average Rating
4.2 out of 5 stars
You are currently viewing the reviews that provided a rating of 3 stars. Click here to see all reviews.
Not bad!
By , for WP 4.2.4

Has everything you would expect in terms of watermark placement, opacity and scaling.

Lets you pick which image formats to watermark.

Code is decent. Has filters where it makes sense.

Docking a star because it does not use WP_Image_Editor to perform transformations, and another because the support forum isn't well kept.

help :)
By ,

Its not working for me.. I installed, activated, and nothing shows up as an option when posting images, argh :(

Doesn't seems to work for me
By , for WP 4.0

it seems to be a great plugin and I do use one of your plugin for gallery and works fine, unfortunately this one doesn't seem to work on my site... I don't see any options to add watermark manually on the media library section !!

Thanks

Good!
By , for WP 3.8.1

Nice plugin.

For devs :
1. Image loses transparency after processing.
2. Missing text logo option.

Not compatible with galleries?
By , for WP 3.8.1

I was excited to find this plugin because people are stealing images off my client's site. She has an embossed logo in the corner of her images and people are just chopping that section of the image off!

So I installed and tried this plugin and ran into 2 issues:
1. The opacity scale isn't working at all (I tried this in Firefox, Chrome and IE because I thought maybe it was a browser issue).

2. I'm using the Core Minimalist Photography theme and this Watermark plugin is not showing up as available for batch application to existing galleries.

So, I've wasted a lot of time and effort on something that didn't solve the problem.

Problems With Update 1.2.0
By , for WP 3.7.1

I have been using Version 1.1.4 for some time heavily, the Version 1.2.0 is fine but for me when I have to turn off the automatic feature (in 1.2.0) and finish my task, and return it to back on the watermarking stops. Not with the rollback to 1.1.4, this SHOULD be looked into.

You must log in to submit a review. You can also log in or register using the form near the top of this page.