Plugin Reviews

Genesis Simple Edits

This plugin lets you edit the three most commonly modified areas in any Genesis theme: the post-info (byline), the post-meta, and the footer area.

2 reviews
Average Rating
4.6 out of 5 stars
You are currently viewing the reviews that provided a rating of 1 star. Click here to see all reviews.
Update Generates Warning
By ,

Just did my update and here's the warning that I get:
Missing argument 2 for load_textdomain() in /home/mysite/public_html/wp-includes/l10n.php on line 443

Deactivate it, warning goes away.

Plugin is hacked
By , for WP 3.9.1

You guys need to update this plugin. It's redirecting my sites on to

You must log in to submit a review. You can also log in or register using the form near the top of this page.