WordPress.org

Plugin Reviews

Font Awesome Shortcodes for WordPress

Implements the Font Awesome icon font in WordPress through shortcodes.

7 reviews
Average Rating
4.3 out of 5 stars
Works Great
By , for WP 4.1

A good solution for end users to implement Font Awesome in the editor without coding. This plugin works fine with out-of-the-box pages and posts. I found a plugin conflict with the Black Studio TinyMCE Widget plugin (the editor in the widget throws an error on save after inserting a FA shortcode). I haven't tested it with custom post types.

Also awsome
By ,

This plugin provide a ready to use and complete set of shortcodes for any based theme that use fontawsome. Just great (and awsome).

Does what it says
By , for WP 3.9.2

Lightweight, simple. Nothing more to say ;)

Great
By , for WP 3.9.1

Does its job as advertised. The developer responds quickly. Overall, a great experience with the plugin.

You need at least PHP5.4 and Font-Awesome lib (css+fonts)
By , for WP 3.9.1

FIRST:
If your MCE is messed up after installing this plugin, your server is running PHP under version 5.4!

Change the global php version in your server settings or try to add the following code to your .htacces file (wp root):

AddType x-mapp-php5.4 .php
AddHandler x-mapp-php5.4 .php

(the code can be different on your host, I am using 1und1)

Important: PHP5.5 resolves in compatibility issues with some older plugins or older WP versions. Try then 5.4!

-------
SECOND:
This plugin doesn't include Font-Awesome, it just provides a button+short-code function to your MCE (works great!).

So you have to download the Font-Awesome pack and include it in your theme folder, then include the Font-Awesome css into your main-css file via @import or you copy the content of the FA-CSS to your main-css.

I think this plugin could be improved by a settings page with the option to include font-awesome or just some infos how to activate the frontend functionality of FA. (Not everyone is using a theme with FA included.)

Hope I could help you guys.

Version 4.0.3.8 completely broke wordpress for me.
By , for WP 3.9.1

Bummer, I really wanted this to work. It ended up completely messing up my page and post editor, making it so that I couldn't click on anything other than the WordPress left column menu. The TinyMCE buttons all disappeared too. I also think it's sort of misleading that the plugin only started on version 4 a few weeks ago, instead of calling it version 1. It's now at version 4.0.3.8 making it look like it's been through several rounds of programming. Wrong.

Sweet
By ,

Good Stuff

You must log in to submit a review. You can also log in or register using the form near the top of this page.