WordPress.org

Plugin Reviews

Font Awesome Icons

Enables easy use of the Font Awesome icon font set from within WordPress. Icons can be inserted using HTML, shortcode, or TinyMCE plugin.

21 reviews
Average Rating
3.9 out of 5 stars
Even though it doesnt work out of the box, still a good option
By , for WP 4.5.1

You can get the short codes to work if you are determined.

Use this to get the latest version of icons from Font Awesome:
https://wordpress.org/plugins/dequeue-font-awesome/

Then instead of following the instructions, use short codes with the FA prefix (not "icon"):

[icon name=fa-phone]

Then add this piece of CSS--

i{
display: inline-block;
font-family: FontAwesome;
font-style: normal;
font-weight: normal;
line-height: 1;
-webkit-font-smoothing: antialiased;
-moz-osx-font-smoothing: grayscale;
}

--
to your theme or add it with a CSS plug-in like this:
https://wordpress.org/plugins/wp-add-custom-css/

It is worth it for the short codes. Short of cracking open the PHP, this should get most by until the plug-in is updated. I'd even recommend dropping the 'icon' prefix for the FA in the future to the author.

Great! I love it!
By ,

Great plugin, thanks! Compared to other large Font Awesome plugin, very fast page loading time.

Nice plugin
By , for WP 4.2.4

Works in 4.2.4! Had to read the changelog first though to see that its only compatible with fontawesome 3.2.1 - I was using the html code snippets from fontawesome 4!

Great but...
By ,

It would be a lot better, if there were more social icons like for example bloglovin!

Awersome!
By , for WP 4.1.1

like it

Simple and lightweight. No extra crap.
By , for WP 4.1

A lot of other icon plugins try to pull you into subscriptions to icon-makers or they weigh it down by adding a grid to it...this one's perfect for what I needed it for.

Contrary to a few of the previous reviews, this plugin does work with WordPress 4.0 and up.

not compatible with >4.0
By , for WP 4.1

Sadly this plugin has stopped working with 4.0 and above.

not working with wordpress 4.0
By ,

not working with wordpress 4.0

Not working
By ,

This plugin not work.

Dropdown not working
By , for WP 4.0

The supposed dropdown icon selector is missing.

You must log in to submit a review. You can also log in or register using the form near the top of this page.